Bluetooth mouse stutters when running on battery

Discussion in 'OS X Yosemite (10.10)' started by phero, Oct 17, 2014.

  1. phero macrumors member

    Joined:
    May 3, 2013
    #1
    Hi,

    I've upgraded my MBA to Yosemite today, and I've noticed this little annoying bug. I'm wondering if everyone has this, or if it's just me.

    When running on battery and using a bluetooth mouse, the mouse will stutter occasionally.

    The easiest way to reproduce this is by leaving the mouse in a spot for 3 full seconds, and then starting movement again (while on batterypower). The movement will not start for about a half a second, and then stutterjump to the current location.

    Can anyone confirm this bug? Else I'll do a fresh install to see if it's upgrading that caused it.
     
  2. thisisdallas macrumors regular

    thisisdallas

    Joined:
    Sep 26, 2012
    Location:
    Indiana
    #2
    My Razer Orochi 2013 Bluetooth mouse is working fine. I've not encountered any bugs at all with the mouse in either the beta or the public release. Might be low batteries or the mouse itself? If it works fine on other computers, I'm guessing a clean install might fix the issue.
     
  3. phero, Oct 17, 2014
    Last edited: Oct 17, 2014

    phero thread starter macrumors member

    Joined:
    May 3, 2013
    #3
    I've reproduced the bug on my dads rMBP 15. It has a different mouse. Both mice have full batteries and are from Logitech. Also tested a Magic Mouse, same problem.

    The effect is subtle but definitely noticeable. Again, only happens when running on battery.
     
  4. Event3r macrumors newbie

    Joined:
    Oct 11, 2014
    #4
    Have the same bug since beta 5 with my magic mouse and logitech m557

    ----------

    What happens if you open the bluetooth window in system settings?

    Is ur mouse then running fine?
     
  5. Cythth macrumors regular

    Cythth

    Joined:
    Feb 24, 2013
    Location:
    Lake Jackson, TX
    #5
    I have the same issue with the Apple Trackpad. Usually when I physically move it to a new location, it seems to go away. I'm just grasping at straws here, but I think that since the new Yosemite uses Bluetooth more for handoff/continuity, it somehow affects performance with the mouse/trackpad.
     
  6. Jimi72 macrumors member

    Joined:
    Oct 23, 2013
    #6
  7. Event3r macrumors newbie

    Joined:
    Oct 11, 2014
    #7
    But when I connect my mbp to magsafe2 everything is fine... The problem occours on in battery mode
     
  8. phero thread starter macrumors member

    Joined:
    May 3, 2013
    #8
    Alright, so this seems like a common bug. Good to know.

    ----------

    Just tested. Yeah, the bug disappears when the BT preferences window is in focus, but reappears when I start doing something else. Funny.
     
  9. jmastorga macrumors newbie

    Joined:
    Oct 18, 2014
    #9
    I have exactly the same problem on two macbook pro 9.2. The problem appears only when used with battery.
     
  10. Guy1717 macrumors newbie

    Joined:
    May 26, 2011
    Location:
    Belgium
  11. yep-sure macrumors 6502

    yep-sure

    Joined:
    Sep 21, 2012
    Location:
    Melbourne, Australia
    #11
    +1

    It's driving me crazy! I use a Magic Mouse and it's pretty bad. The trackpad has the same problem but not quite as bad.
     
  12. Marcohildebrand macrumors newbie

    Joined:
    Aug 23, 2014
    #12
    Since upgrading to Yosemite my Apple magic mouse no longer works.

    The mouse worked intermittently with jerky pointer movements and I kept getting bluetooth connected/connection lost messages on the screen.

    So I replaced the batteries no improvement then I deleted the connection and now the mouse cannot be found.

    It worked perfectly before the upgrade, I have a Macbook pro retina late 2013
     
  13. anlu4433 macrumors newbie

    Joined:
    Aug 19, 2010
    #13
    I confirm this with Magic Touchpad.
    Hadn't noticed that it only occurs when on battery power.

    So frustrating and non-acceptable.
     
  14. Macula macrumors 6502

    Macula

    Joined:
    Oct 23, 2006
    Location:
    All over the place
    #14
    It seems that this blue tooth needs a filling. Is the mouse the sole BT device that's paired with your Mac?
     

Share This Page