Bluetooth Mouse + Time Machine = Slow Mouse

Discussion in 'MacBook Air' started by sanPietro98, Apr 20, 2009.

  1. sanPietro98 macrumors 6502a

    sanPietro98

    Joined:
    May 30, 2008
    Location:
    28.416834,-81.581214
    #1
    I just upgraded from a MBA rev A to a rev B. I experienced this with both machines, so it's not just a rev A issue...

    I use a Bluetooth Mighty Mouse and everything is fine... until my hourly wireless Time Machine backup starts. Then the mouse cursor becomes very choppy and sluggish. As soon as the hourly backup completes, the mouse's responsiveness returns to normal. Throughout all this, the trackpad is just as responsive as always -- no change there. I don't have another bluetooth mouse to see if its just the Mighty Mouse.

    When this happens, the Activity Monitor is not spiked. The fans aren't running loud (so I don't expect its an overheating issue). This doesn't happen during a large wireless download -- just Time Machine. It's not a big deal, but rather an annoyance.

    Any ideas why? Or even more to the point, any ideas on how to fix it?
     
  2. spaceballl macrumors 68030

    spaceballl

    Joined:
    Nov 2, 2003
    Location:
    San Francisco, CA
  3. sanPietro98 thread starter macrumors 6502a

    sanPietro98

    Joined:
    May 30, 2008
    Location:
    28.416834,-81.581214
    #3
    That's true. But there are some applications where a trackpad just doesn't cut it. I have been doing a lot of work lately with OmniGraffle Pro's bezier curve tool. And with a trackpad, that is a pain because very precise cursor movements are sometimes needed.

    But I'm surprised no one else has noticed this bluetooth mouse issue on the MBA.
     
  4. Bye Bye Baby macrumors 65816

    Bye Bye Baby

    Joined:
    Sep 15, 2004
    Location:
    i(am in the)cloud
    #4
    Is it a general thing or MBA?

    i don't have a problem.
     
  5. duky macrumors 6502

    Joined:
    Jun 25, 2007
    Location:
    North Carolina
    #5
    I have bluetooth Mighty and iMac and never had this issue..might be a MBA thing?---But that makes little sense..
     
  6. aristobrat macrumors G5

    Joined:
    Oct 14, 2005
    #6
    I'm having a similar issue with my new MBP. I'll have to look to see if Time Machine is backing up to my Time Capsule when this happens
     
  7. locust76 macrumors 6502a

    Joined:
    Jan 23, 2009
    #7
    Bluetooth and WiFi run on the same 2.4 ghz frequency range. Radio interference?
     
  8. leodavinci0 macrumors 6502

    Joined:
    Jan 26, 2006
    #8
    I'm guessing that your TM HDD is connected through USB? Bluetooth uses the USB bus for I/O, thus during the backup the bus is becoming maxed out...maybe. I've had issues with my old PB doing this when I have more than 3 things active through USB (e.g. bluetooth mouse, bluetooth keyboard and iPhone).
     
  9. simore macrumors newbie

    Joined:
    Apr 22, 2009
    #9
    me too!

    I have exactly the same problem when backing up to my wireless TC, I didn't have it with exactly the same mouse and TC when using a unibody macbook pro. It took me by surprise and i was actually pretending it didn't happen and just stopping the backup to solve it until i saw it here!
     
  10. sanPietro98 thread starter macrumors 6502a

    sanPietro98

    Joined:
    May 30, 2008
    Location:
    28.416834,-81.581214
    #10
    It's all wireless. My Time Machine disk is attached by USB to a 2008-edition Airport Extreme Base Station. The MBA doesn't physically touch the Time Machine disk. Actually, when this happens, nothing is attached to the USB port.
     
  11. sanPietro98 thread starter macrumors 6502a

    sanPietro98

    Joined:
    May 30, 2008
    Location:
    28.416834,-81.581214
    #11
    That's a good possibility. However, I don't see the same mouse "lag" when wirelessly downloading a large file through Safari. It's only during TM backups.

    It could be that HTTP TCP streaming isn't using as much bandwidth as Time Machine. But that's pure speculation -- I'd have to look at the Activity Monitor to see how much network traffic is being used in both.
     
  12. daisun macrumors newbie

    Joined:
    Feb 16, 2009
    #12
    Generally your home network bandwidth be it wireless or wired is significantly higher than your internet bandwidth so downloading a large file over the internet while connected to your home network wirelessly wont cause excessive wireless activity.

    I find that when I copy a large file over my wireless network it affects the operation of my wireless mouse. My mouse isn't bluetooth it uses a usb dongle.

    I assume that it is the high amount of wireless transmission which is interfering with the mouse.
     
  13. dudup macrumors regular

    dudup

    Joined:
    May 28, 2008
    Location:
    São Paulo, Brazil
    #13
    I have some occasional problems on my rev. a alu iMac, never had a problem with my rev. a MBA.

    It's been a long time since the last time it happened, but I live in a area with tons of radio interference, so I blame 2.4ghz interference.

    I just have to quickly turn my MM off and on again and it works. Just like Roy says on The IT Crowd (LOL)
     
  14. bryanus macrumors member

    Joined:
    Jul 19, 2005
    #14
    It's caused by using Time Machine over Airport

    I'm having the same issue. My BT keyboard won't even connect while Time Machine is backing up over WiFi from my MBP. If I switch the connection to Ethernet, the keyboard works fine.
     
  15. aristobrat macrumors G5

    Joined:
    Oct 14, 2005
    #15
    My mouse still acts extremely slow when my MBP is backing up wirelessly to the Time Capsule, if my MBP is using 2.4GHZ wifi. It used to outright disconnect, ... hasn't done that in awhile.

    If I have the MBP using the 5.0GHz wifi, the mouse does better. Still a little slower, but it's at least usable.

    (My Time Capsule is setup to use 2.4ghz for b/g network, and 5.0ghz for the faster n network)
     
  16. Gadgetman99 macrumors regular

    Joined:
    Sep 1, 2009
    #16
    Backing up every hour seems excessive. Maybe backup once/day? At least the frustration would be once/day instead of every hour.
     
  17. Mark-Mac-Attack macrumors regular

    Joined:
    Apr 6, 2007
    Location:
    England
    #17
    Bump.

    I have this problem all of the time. Is there any known cure yet?

    Regards,
     
  18. sab46 macrumors newbie

    Joined:
    Oct 21, 2008
    #18
    Change the channel

    I've had the same issue with my macbook. The mouse gets very 'jumpy' when time machine runs (backup HD is connected to an airport extreme, mouse is a non-bluetooth usb wireless mouse). I'm almost certain the issue is with wireless interference.

    Try changing the channel used by your time machine/wireless router. I've found that come channels cause less interference than others. However, none of them are interference free for me.

    FYI, the wireless network bandwidth is much higher when performing a backup than downloading a large file from the internet. To prove it, try copying a large file from your laptop to a USB drive connected to the wireless router. You'll probably see the same behavior as when you run a backup.

    --Sal
     
  19. dimension6 macrumors newbie

    Joined:
    Nov 12, 2008
    #19
    The problem is absolutely radio interference. Bluetooth and 802.11b/g frequencies overlap in the 2.4Ghz range. You can confirm this by using your Bluetooth mouse next to a microwave oven that's on (that also uses the unlicensed 2.4Ghz spectrum). A solution would be to switch your AP to the 5Ghz band (available with either 802.11a or some 802.11n APs). However, many devices (particularly small things like the iPhone or netbooks) don't support 5Ghz networks. I have a dual-channel Cisco AP, one channel 2.4Ghz and one channel 5.0Ghz. This setup works well in my apartment. One disadvantage of 5Ghz networks is that the range is shorter, however. Also, you obviously can't force your neighbors to stop using their 2.4Ghz networks, since it is unlicensed spectrum (meaning available to all). In my central Tokyo apartment, there are nearly 40 APs within range, nearly all of which are operating in the 2.4Ghz range.
     
  20. dimension6 macrumors newbie

    Joined:
    Nov 12, 2008
    #20
    Changing the channel may help some, but there are only three nonoverlapping channels available for 802.11b/g networks, so it gets crowded quickly. You can view good information on channel deployment issues here.
     
  21. marksman macrumors 603

    marksman

    Joined:
    Jun 4, 2007
    #21
    I know this is an old thread, but I just wanted to note it solved a mystery for me.

    I was about to chuck my mouse across the room because I could not find out why it was so sluggish.

    I had been using vmware fusion, and had the hdd I use for time machine on the windows setup, so Time Machine had not backed up for a while. I then went and shut down vmware so it could back up to the drive, and my mouse has been slow as all get out. The drive is on usb, so thanks for this thread educating me about what was going on before I tore my hair out.
     
  22. remoteONE, Nov 26, 2010
    Last edited: Nov 26, 2010

    remoteONE macrumors newbie

    Joined:
    Aug 19, 2010
    #22
    BT mouse Lag

    Also reported at
    http://discussions.apple.com/thread.jspa?messageID=12659782#12659782

    I have MB 13" OSX 10.6.4
    Any Wireless Network activity causes problems with the BT Mouse.
    Ive a Logitech V470 connected to the internal MB BT port, another Kingston BT mouse that uses a USB dongle and a MS BT wireless KeyBoard/Mouse using a USB dongle.
    All have the same issue when transferring Wireless data.
     
  23. remoteONE, Nov 28, 2010
    Last edited: Dec 1, 2010

    remoteONE macrumors newbie

    Joined:
    Aug 19, 2010
    #23
    Update:
    Upgraded to 10.6.5 - No difference..
    Changed/tried all wifi channels - No change to problem.
    Tried a Mac Mighty Mouse - slightly less effect but still unusable.
    Tried a USB BT external dongle type mouse (not using internal BT AP) - Same issue
    Tried on a friends Wireless Network - Problem only slightly evident - to be expected as this was a slow network at about 1.9MB/s, a transfer speed that does not show the problem.
    Tried using a Netgear wireless router - Problem is only slightly evident on Mac Mighty Mouse, worse on Logitech, evident slightly on ext BT mouse.
    Note also: With the Wireless nw running a transfer at 3MB/s, this Network speed drops down to a very slow speed when the "Set up Bluetooth Device" utility is initiated.

    So given that this issue is also experienced by MacBook owners when using BT mouse while doing a File transfer via USB external HDD, or Time Machine. My conclutions are either:
    1.
    The USB ports, BT chipsset and Airport Chipset are all using the same data bus in the Macbook.
    This data bus is not capable of running at high speed, contiguous data transfer in a single direction AND transfer BT wireless data at the same time.
    Apple Architects may be able to work around this issue by appling higher priority to BT data transfer tasks (Mouse), as it does when the "Set up Bluetooth Device" utility is running.

    or
    2. The BT wireless hardware is easily susceptible to RF interference. This dont explain USB drive influences however.

    My best bet is to log a Hardware repair request with Apple, as this is indeed a Hardware issue.

    MacBook Mac OS X (10.6.5) Wireless BT Notebook Mouse
     
  24. PirateP macrumors 6502

    PirateP

    Joined:
    Aug 3, 2010
    Location:
    Naboo Land
  25. remoteONE, Dec 1, 2010
    Last edited: May 10, 2011

    remoteONE macrumors newbie

    Joined:
    Aug 19, 2010
    #25
    Apple Support has given an MBPro user a solution here:
    http://discussions.apple.com/thread.jspa?messageID=12659782#12659782

    I was also having this same issue, not only with a BT mouse but a Corded USB mouse also. I tried the "procedure" at the above link, repeated below, and it seems to have fixed it.

    This is the Apple suggested way to resolve (for Mac Book PRO purchased OCT 2010 - apparently there are different functions for different hardware).
    Good video of it here: http://www.youtube.com/watch?v=oIhhsRut2bU

    1) Press and hold: SHIFT + Control + Option
    2) whilst holding the above button combination - press POWER BUTTON once only, then release
    3) Shut down machine
    4) Power on machine - at first chime (not before), PRESS and HOLD: COMMAND + OPTION + (letter P) + (letter R) don't let go - hold until second chime
    5) Release after second chime

    This also worked for my MacBook 13".
    Ive found that I need to repeat this procedure every week or so to make the mouse (simple corded usb mouse) work again.
    The mouse just gets more clunky, laggy and jumpy every day until I reset the PRAM n VRAM this way. Bl-o-o-dy Ridiculous , but at least I can use it.
    This (Command-Option-P-R) Resets PRAM and NVRAM , removing stored settings etc.
    http://macs.about.com/od/usingyourmac/qt/Reset-Pram.htm
    http://support.apple.com/kb/ht1379
     

Share This Page