Bluetooth Not Available

Discussion in 'MacBook Pro' started by ScaldedApe, Dec 3, 2013.

  1. ScaldedApe macrumors newbie

    Joined:
    Dec 3, 2013
    #1
    Hi everyone,

    I'm hoping that someone can help with a problem. I have a 2009 Macbook Pro 17" running 10.9 and last night the bluetooth disappeared. I had an issue with the SSD in my macbook and swapped it out, and when I switched it back on the bluetooth wasn't working. It seems to be running ok otherwise.

    i have a zigzag line going through the bluetooth icon on the menu bar. I Googled the "Bluetooth not available" message the menu bar icon give me, and theres a lot of info and recommendations to reset the SMC and the PRAM.

    I've tried to reset both but the PRAM reset won't work !! CMD / ALT / P & R together, but it just boots as normal. I've checked the buttons and they all work. The SMC seems to reset because the magsafe led changed colour when I let the keys go.

    The bluetooth option in system prefs has disappeared and the bluetooth exchange app says I have no bluetooth hahaha

    I've tried lots of different things that I'll try to remember and list below

    SMC reset
    PRAM reset doesn't seem to work
    Deleted - com.apple.Bluetooth.plist and restarted (Found a recommendation for that online)
    Repaired Permissions with disk utility - Lots of repairs needed, then restarted but still not working
    Reinstalled from Time Machine both most recent and old
    Clean installed Mavericks - Same issue
    Clean installed Mountain Lion - Same issue
    Clean installed Leopard - Bluetooth was completely missing from OS

    It seems that this happens to a lot of people, but the SMC reset sorts it for them ! Just not me !

    I called Apple and I have an appointment with the Genius bar in 10 days, but I was hoping someone could help now.

    Many thanks

    J
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #2
    Seems the problem is physical since it happen when you had the MacBook open. Probably something got bumped.
     
  3. ScaldedApe thread starter macrumors newbie

    Joined:
    Dec 3, 2013
    #3
    I may have found the issue, but I want to run it by others first ....

    I opened the back up again this mooring to see if anything obvious was wrong, but then I don't know what Im doing so didn't investigate very hard. I did notice though that a cable that goes to what I think is the Bluetooth module / radio thing is very loose.

    This one (Taken from fixit and comedy arrow added)

    [​IMG]

    The cable going into the metal connector is very flimsy and feels like it would break if I looked at it to hard !!! Could this the problem ?

    I've found a "Macbook Unibody 17" iSight cable" in the US that looks like its the one that would replace this. Its not that expensive and postage to the UK is ok, but I want to see what you guys thought before I spend any money on this.

    Thanks
     
  4. ScaldedApe thread starter macrumors newbie

    Joined:
    Dec 3, 2013
    #4
    Fix it

    It's taken a while for the cable to get across from the US but last night I stripped the Macbook down and fitted the new cable. Taking the whole machine apart including the glass & led screen was nerve wrecking but it all went well.

    I have working bluetooth now lol

    Thanks for the help
     

Share This Page