Bluetooth Not Showing Up in Menu Bar

Discussion in 'MacBook' started by HIMAN1998, Sep 13, 2013.

  1. HIMAN1998 macrumors 6502

    HIMAN1998

    Joined:
    Jan 24, 2013
    Location:
    Richmond, VA
    #1
    There is no icon for Bluetooth in the menu bar, even when show bluetooth in menu bar is checked. If I click in the area that it's supposed to be in, there is a button for it. No icon, though. Attached is a screenshot. Screen Shot 2013-09-13 at 7.48.22 PM.png

    How do I fix this? I'm on Mountain Lion with a late 08 MacBook unibody. I've tried resetting the PRAM, resetting the SMC, and kept clicking the check on and off. Nothing has worked.
     
  2. madmacfan macrumors 6502

    Joined:
    Feb 19, 2012
    Location:
    London, United Kingdom
    #2
    I've come across this too since updating to 10.8.5 .If anyone has a fix or workaround, i'd greatly appreciate it
     
  3. HIMAN1998 thread starter macrumors 6502

    HIMAN1998

    Joined:
    Jan 24, 2013
    Location:
    Richmond, VA
    #3
    I just put SMCFanControl on here and it looks odd having a blank space beside the monitoring thing.
     
  4. HIMAN1998 thread starter macrumors 6502

    HIMAN1998

    Joined:
    Jan 24, 2013
    Location:
    Richmond, VA
    #4
    weird, when I updated to 10.8.5, the Bluetooth icon reappeared.
     
  5. madmacfan macrumors 6502

    Joined:
    Feb 19, 2012
    Location:
    London, United Kingdom
    #5
    Hi, did you use the 10.8.5 combo update or the delta update. Just trying to gauge where the issue lies. Thanks
     
  6. HIMAN1998 thread starter macrumors 6502

    HIMAN1998

    Joined:
    Jan 24, 2013
    Location:
    Richmond, VA
    #6
    I don't know which I downloaded, I just did the one through the App Store.
     
  7. madmacfan macrumors 6502

    Joined:
    Feb 19, 2012
    Location:
    London, United Kingdom
    #7
    Thanks. I think it may be possible to replace the new icon under bluetooth.menu with the old one from 10.8.4 located through the go to finder option in /System/Library/CoreServices/Menu Extras/ but as I no longer have any of my macs running 10.8.4, I've not been able to try this out. If anyone still on 10.8.4 could upload a copy of this file, I'll try it out to see if it works, then will probably make an automated gui for those less tech savvy if all goes well.

    Thanks
     
  8. madmacfan macrumors 6502

    Joined:
    Feb 19, 2012
    Location:
    London, United Kingdom
    #8
    I've come up with a fix for those using a black menubar like myself but haven't as yet done a fix for the default mac menubar like the one in your attached image. i've not tried the default Bluetooth.menu file from 10.8.4 as yet as i don't have access to a mac running 10.8.4 as all my macs have been upgraded to 10.8.5. i'll try and make up a fix for the default mac menubar and report back on how i get on.
     
  9. HIMAN1998 thread starter macrumors 6502

    HIMAN1998

    Joined:
    Jan 24, 2013
    Location:
    Richmond, VA
    #9
    Now that I remember, this started happening after I used the Black Menu Bar. I didn't like the look and took it off and this started happening.
     
  10. madmacfan, Sep 15, 2013
    Last edited: Sep 15, 2013

    madmacfan macrumors 6502

    Joined:
    Feb 19, 2012
    Location:
    London, United Kingdom
    #10
    If you had problems after uninstalling one of the black menubar mods available, you can either get in touch with the dev who created it, i.e through deviant art, or if you're still having issues you can use the package file i posted below to put things right. If all is well it may be a good idea to download the file anyway just in case things mess up again.

    https://dl.dropboxusercontent.com/u/41388906/bluetooth.pkg
     

Share This Page