Bluetooth on New MacBook unibody "lost"?

Discussion in 'MacBook' started by f-our1, Jan 11, 2009.

  1. f-our1 macrumors newbie

    Joined:
    Jan 11, 2009
    #1
    My new MacBook unibody has been working flawlessly for about two months and today bluetooth desided to stop working. When I look in "about this computer" it says that there is no Bluetooth device on my laptop.

    I have ran the Hardware test (Hold in "D" upon start up) but it says its fine.

    Help?
     
  2. JustOneQuickONe macrumors 6502

    Joined:
    Dec 4, 2008
    #2
    I had this problem on my macbook white. I just restarted the computer as I normally do and i went back to working. You may need to restart it more than once, maybe even trn it off let it sit a few seconds then turn it back on.
     
  3. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #3
    Take it to the Apple Store.

    I've had the same issue on my MB (see sig), the bluetooth module or cable wll occasionally fail. They will replace it no problem.
     
  4. aethelbert macrumors 601

    Joined:
    Jun 1, 2007
    Location:
    Chicago, IL, USA
    #4
    This happens to me probably once a month. A restart always fixes it.
     
  5. f-our1 thread starter macrumors newbie

    Joined:
    Jan 11, 2009
    #5
    But when you (I) pay real $$$ for a nice laptop you (I) want it to work every time, I shouldn't have to restart it for a thing that is standard if you know what I meen.
     
  6. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #6
    You're right, there is an underlying problem there. Take it in.
     
  7. kastenbrust macrumors 68030

    kastenbrust

    Joined:
    Dec 26, 2008
    Location:
    North Korea
    #7
    its not the laptop, bluetooth was developed by Sony, and yes its unreliable we all know.
     
  8. Since OS-6 macrumors newbie

    Joined:
    Mar 5, 2009
    Location:
    South Australia ( it's a State )
    #8
    Me Too.

    FORUM VIRGIN HERE !
    First ever post . . .

    Thought I should add my voice to the others having the same problem.

    This just happened to me, with my squeeky clean, brand new ( just two months old ) MacBook. Not impressed, if I am having to be for ever restarting.
     
  9. MuDPHuDStudent macrumors member

    Joined:
    Feb 8, 2009
    Location:
    Hanover, NH
    #9
    Restarting may not be enough. You may need to reset the SMC. That worked for me the last time I "lost" my bluetooth.
     
  10. Mortman macrumors newbie

    Joined:
    May 12, 2009
    #10
    MacBook Bluetooth Fix

    I posted a fix for the lost bluetooth last May. Here it is briefly:
    I got this through Apple's Help line

    Unplg while computer is on (MacBook)
    While still running, pull the battery.
    With battery out, press and hold the ON button for 10 seconds.
    Replace the battery - restart.
    Bluetooth should once again be on the upper bar.
     
  11. mr.steevo macrumors 65816

    mr.steevo

    Joined:
    Jul 21, 2004
    #11
    Hi,

    The unibody makes it harder to pull the battery.

    You could run the battery "dry" but even then there would still be energy left in the cells. Just one of the issues of the new battery design I suppose.

    s.
     
  12. Grahamwollombi macrumors newbie

    Joined:
    Jul 11, 2011
    Location:
    Sydney
    #12
    Lost Bluetooth

    Just to let others know, I have a Macbook Pro 2.4 GHz Intel Core 2 Duo and lost Bluetooth today. After various attempts including restarting, I found this forum and followed the steps suggested by Mortman and it worked. Thank you.:)
     

Share This Page