Bluetooth on only on charging?

Discussion in 'iOS 7' started by vexorg, Oct 6, 2013.

  1. vexorg macrumors 6502a

    Aug 4, 2009
    I've had a search and due to too many common terms cannot find answer.

    I want my bluetooth only to be switch on when it is connected to a charger, is there a setting somewhere that allows this?

    One of my old motorola phone used to have profile config for charging, or silent, etc. I cant see anything like this on the iPhone.

    I want the bluetooth to be active when I plug the phone into the car charger so that it then links to the car phone system, then turn off bluetooth when unplugged.

    It's so easy to forget to turn off bluetooth and the battery runs out before you realise it's been left on.
  2. Tyler23 macrumors 603


    Dec 2, 2010
    Atlanta, GA
    There is no setting for this.
  3. vexorg thread starter macrumors 6502a

    Aug 4, 2009
  4. deeddawg macrumors 604

    Jun 14, 2010
    What phone do you have?

    I've pretty much always left Bluetooth turned on with every iPhone since the 3GS since noticing it made no significant difference to battery life in my usage.

    Why do you suppose your experience is so dramatically different?
  5. Sital macrumors 68000


    May 31, 2012
    New England
    Yep, I have bluetooth on 24/7 and don't have a problem with my battery running out.
  6. vexorg thread starter macrumors 6502a

    Aug 4, 2009
    iphone5, it's my wife's phone, she said she's noticed the battery drop whenever she leaves bluetooth on.
  7. plainwhitetay macrumors regular

    Dec 28, 2010
    North-east, Indiana
    I always keep bluetooth on myself, and I still get a full day out of a charge so it doesn't bother me. Unfortunately, there's no settings for what you want on the stock iOS.
  8. squeakr macrumors 68000


    Apr 22, 2010
    I leave BT on and never turn it off and have no battery life issues and have done this since the days of my 3G iPhone.

    If she is on IOS7 does she also have airdrop on as that can eat into battery. Swipe up in control center and select airdrop and then select off.

Share This Page