Bluetooth problem '09 MPro

Discussion in 'Mac Pro' started by macmesser, Apr 16, 2014.

  1. macmesser macrumors 6502a

    Joined:
    Aug 13, 2012
    Location:
    Long Island, NY USA
    #1
    I was unable to pair a magic trackpad with my home computer, which just wasn't seen. Also, an Apple wireless keyboard paired but keeps losing connection. I reset PRAM, SMC and the problems persisted. Both peripherals (new) are working fine on my office machine, which is almost identical to my home computer. Does this sound like my bluetooth on my home machine is failing? How can I test it, and if it is not necessarily failing what could be the cause of problems? Perhaps multiple attempts to pair new devices corrupted something? Any prefs files that might be relevant? I'm looking for possible fixes which don't assume a Bluetooth hardware problem. Ideas appreciated.
     
  2. macnjack macrumors member

    Joined:
    Oct 11, 2011
    #2
    My 2011 iMac suffered from the 2.4Ghz, channel 6 interference issue. So check your home router settings and move to channel 1 or 11 (i think those are it).

    Basically I had huge latency between typing and character input, laggy trackpad, and frequent disconnects. I thought it was my razer driver software as i had just installed it. Problem came back and I noticed it was occurring more often during heavy wifi usage.

    I had forgot I just switched channels after running wifi analyzer and found the solution on another forum...which i could give credit where due. Apparently this is well documented somewhere but googling didn't turn up much.

    Switching channel to 1 instantly solved the problem. Last gen airport extreme router hardware.
     

Share This Page