Bluetooth Problem - "Pairing took too long"

Discussion in 'iPhone' started by Colin Len, Jun 25, 2013.

  1. Colin Len macrumors newbie

    Joined:
    Oct 7, 2011
    #1
    I recently purchased this Bluetooth audio receiver with the intention of using it to play audio from my ipad/iPhone thru the stereo in my garage - and if the results were good I was going to get one for the car too. My problem is that I cannot get it to pair with either of my devices. I keep getting this warning:

    [​IMG]


    I tried multiple times, powered the receiver off a couple times, made sure it was fully charged... I'm familiar with how to pair things, so I don't think its a user error situation. And I was easily and quickly able to pair my gf's android phone on the first attempt. I also just managed to pair it to my iMac, however it quickly changes from paired and connected to paired and disconnected - I'm not 100% sure what that means. Possibly it just means means its idle, I didn't try playing music thru the receiver from my iMac because I didn't have an aux cable or stereo handy in the room with the computer.

    Any help on getting this paired w my iOS devices would be greatly appreciated. Thank you!
     
  2. robntarn macrumors newbie

    Joined:
    Jan 4, 2014
    Location:
    Australia
    #2
    iPhone / iPod pairing

    Also having the same problem attempting to pair to a brand new, out-of-the-box, Veho 360bt Bluetooth speaker. Have tried iPhone4 ios6.1.3, iPhone4s ios 7.0.4, 4 Month old iPod Nano Model PD477ZP, & iPhone5 6.0.2.

    All detect the device and its name is displayed in bold black letters.
    From that, I feel the Bluetooth on the device is working.

    iPhones say it is taking too long, the iPod just say to check the device is turned on & in range.

    Have tried numerous off/on reset combinations. Problem is always the same.

    All similar stories and suggestions welcome.
     
  3. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #3
    OK, did you read the instructions?

    Typically you put the receiver in pairing mode, then on you phone, within a limited amount of time, you must enter a password, many times it's 0000. This is a once-off operation.
     

Share This Page