Bluetooth Unavailable

Discussion in 'iPhone Tips, Help and Troubleshooting' started by marlo stanfield, Mar 23, 2008.

  1. marlo stanfield macrumors newbie

    Joined:
    Mar 23, 2008
    #1
    I have a jailbroken 1.1.4 iphone and in Settings it says that the bluetooth is unavailable. Bluetooth was working for awhile while it was jailbroken, then all of a sudden it went 'unavailable.' I have tried several things and rebooted but nothing is working. Has anyone experienced this or know how to troubleshoot?
     
  2. mJaY macrumors newbie

    Joined:
    Feb 5, 2008
    #2
    Its Stupid and strange at the same time..

    I unlocked hundreds of phones without anyproblems

    I baught 16 gb unlocked thorugh ZIPHONE 3.0

    It wirked fine some time . now Installer works at snail speed, just tap once , SIT and RELAX to see the result of that tap . and BLUE TOOTH says unavailable.

    anyone with any solution ??????? or should i Experiment thsi on my own :s
     
  3. JUNGLE JAZZ macrumors newbie

    Joined:
    Apr 8, 2008
    #3
    bluetooth

    I've been trying to do a bluetoorh sync with my Palm Zire and the message I get is that the port is unavailable and in use by another application. I know they'e talking because I can beam things from the Macbook to the Zire. (I'm new with the Mac thing by the way)
     
  4. tabor macrumors newbie

    Joined:
    Apr 13, 2008
    #4
    Bluetooth Unavailable

    I had the same problem with my iphone 1.1.4, bluetooth unavailable and the installer running very sluggish. I uninstalled the 1.1.4 Compatability Patch and SUID Lib Fix. My bluetooth was immediatley available and installer was back to normal. I am not sure which app was causing the problem, I uninstalled both at the same time.
     
  5. kbates macrumors newbie

    Joined:
    Jun 1, 2008
    #5
    It's the 1.1.4 Compatibility Patch

    After searching all over the place, for an answer to this same problem, I tried uninstalling the 1.1.4 patch, and Bluetooth came back immediately. I've had the SUID fix in place before, but didn't find it when I went to uninstall. Seems that the 1.1.4 'compatibilty' patch isn't that compatible after all...

    Thank goodness for this thread! Hope this helps someone else!
     
  6. zeGenius macrumors newbie

    Joined:
    Apr 5, 2011
    #6
    Bluetooth unavailable

    Hi,

    For all those who have jailbroken iPhones and who can see:

    Settings > General > Bluetooth (grayed out "Unavailable")


    Can you please tell me the setting of the key "Disabled" in:

    /System/Library/LaunchDaemons/com.apple.BTServer.plist


    I've been facing Bluetooth issues ever since iOS3:
    - also used to cause massive battery drain
    - so I manually toggled "Disabled" from "<false/>" to "<true/>" in the above plist
    - battery lasts longer now and
    - i see "Bluetooth" unavailable


    I think most likely some previous version of an installed app toggled this value for you, and forgot/was unable to set it back

    If you have Disabled=true, try to:
    - make Disabled=false and
    - hard-reboot the iPhone (viz. Hold Sleep and Home buttons till the apple logo shows up)



    Greetz
     

Share This Page