Bluetooth/WiFi related issues

Discussion in 'MacBook Pro' started by kwijbo, Jul 9, 2014.

  1. kwijbo, Jul 9, 2014
    Last edited: Jul 9, 2014

    kwijbo macrumors regular

    Joined:
    Jan 28, 2012
    #1
    My 2 week old 15" rMBP base is having some odd issues. When I originally got the computer I set it up with an Apple bluetooth keyboard and a Belkin YourType keypad, also bluetooth. I was on a wifi connection as well and had no issues at all.

    As of two days ago I'm now trying to use both bluetooth items with wifi again, but on a 3G router (not that it should make any difference). Every time I connect a second bluetooth item I get bounced off wireless, doesn't matter which one is connected first. I also am having trouble connecting to protected networks.

    Everything was fine this morning til I put the computer to sleep for about 2 hours at lunch. I've tried NVRAM reset, SMC, reset router, added and removed the network and peripherals about 15 times and about 10 reboots and this is the only sort of pattern I've found. Any ideas?
     
  2. kwijbo thread starter macrumors regular

    Joined:
    Jan 28, 2012
    #2
    While Googling I found someone with the exact same issue:

    http://apple.stackexchange.com/ques...ook-pro-2-4ghz-wifi-no-network-throughput-why

    After fidgeting around with it more I realized my BT keyboard, the BT keypad, my Logitech M570 and my wifi from the 3G router are all on 2.4 Ghz. It worked in my prior environment last week as that router was 5 Ghz capable.

    I'd hope this isn't an issue specific to MBPs so maybe a mod can move it to a more general forum? Although the guy in the prior link seems to have the exact same model as me, maybe we can wait a bit to try and narrow it down some more. I'm on 10.9.4 if that helps.

    Can anyone volunteer a few minutes with some bluetooth devices and 2.4 Ghz wifi and test out this config to see if they are having the same issues?
    It would be much appreciated. Thanks.
     

Share This Page