Bold/Strong fonts are blurry (PIC)

Discussion in 'macOS' started by closet geek, Jun 1, 2007.

  1. closet geek macrumors member

    Joined:
    May 31, 2007
    #1
    I've been using a powerbook for over 2 years and the fonts were always crisp in every app. I've had my MacBook for just over a day and I have noticed certain bold fonts in webpages look pretty awful:

    [​IMG]

    I have tried every font smoothing setting. Turning off text smoothing for all fonts greater than 12 works in most cases but it's hardly a solution as then all text looks horrible not just bolded text.

    I notice this most in Camino and Safari but that doesn't mean it's not happening everywhere in the operating system.

    Thanks.
     
  2. zero2dash macrumors 6502a

    zero2dash

    Joined:
    Jul 6, 2006
    Location:
    Fenton, MO
    #2
    Could be the screen/display, could be a font issue.

    Open Font Book, select all the fonts and choose "Validate Fonts" from the File menu; see if you have any problems. If you do, it's a font problem. Although - it may not give you an error and it could still be a font problem. Have you tried changing what character encoding and/or fonts are used to display webpages?

    Have you tried hooking up to an external monitor?

    There's a couple ideas at least to get you started...;)
     
  3. WillJS macrumors 65816

    WillJS

    Joined:
    Jan 6, 2007
    #3
    Hmm... my macbook seems to have this same problem. black text on white backgrounds (how im typing now) fonts arent really chrisp. It must be a display problem because it doesnt do it on my macbooks LCD external.. if there's a fix, I'd love to know it.
     
  4. Richard Flynn macrumors regular

    Joined:
    Sep 4, 2006
    Location:
    Sydney
    #4
    I must confess that I can't really see any problem with the screenshot you posted.

    Is it possible that you are slightly zoomed-in, albeit inadvertently? Hold down Command (Apple) and do two-finger scrolling in either direction (scroll down to zoom out all the way). Alternatively, there is the Zoom setting (off by default) in the Universal Access preferences (in System Preferences).
     
  5. apfhex macrumors 68030

    apfhex

    Joined:
    Aug 8, 2006
    Location:
    Northern California
    #5
    As far as that screenshot goes, it looks crisp and normal to me, so it must be something like the Universal Access zoom or maybe a resolution issue.
     
  6. closet geek thread starter macrumors member

    Joined:
    May 31, 2007
    #6
    I checked the zoom and it was off. It is the same in every resolution also.

    I'm finding myself surprised that people are not seeing it in the screenshot! As I said, I had a powerbook and fonts always looked so crisp. This really does only leave the fact I'm using a glossy screen that is causing this?
     
  7. Arne macrumors regular

    Joined:
    May 14, 2006
    Location:
    Germany
    #7
    I had a similar issue on an external LCD screen. I had to change the repeat-rate of the screen (it was 70hz by default, needed to be 60hz). Maxbe there is some option like this you can change?

    Arne
     
  8. masse macrumors 6502a

    masse

    Joined:
    May 4, 2007
    Location:
    MA/GA
    #8
    Don't listen to the people that say it looks fine. It doesn't. I've never had a problem with text smoothing on my powerbook. Generally everything looks beautiful.

    My dad's T-60 has a similar issue though even with font smoothing off. It just doesn't look crisp. Since it's noticeable in the screenshot it's definitely not a hardware issue.


    Make sure to use the highest resolution the macbook supports. I just noticed that with my powerbook on a lower resolution the anti aliasing looks excessive (font smoothing).

    Come to think of it..the T-60 isn't on the highest resolution so I dont know maybe that's your problem.
     
  9. RCElectricFlyer macrumors member

    Joined:
    May 5, 2007
    #9
    I have noticed the same thing. The text "blooms" a bit. It is very noticeable when I switch from the PC to the Mac on the Dell monitor I am using. I assume it is a text smoothing "feature". I'd like to know how to fix this "feature". :)

    Rob
     
  10. closet geek thread starter macrumors member

    Joined:
    May 31, 2007
    #10
    Hi,

    I'm afraid the refresh rate is greyed out here and the resolution is at its highest setting.

    Here is two further screenshots, one in Camino:

    [​IMG]

    and in Safari:

    [​IMG]

    Both have identical font settings.

    I'd love this to be as clear cut as "Camino is blurry, Safari isn't" but as I've mentioned before this problem extends to bolded text in menus in OS X in general. It just looks too "big" or "strong" compared to how it used too on my PowerBook. There is definitely a lacking in crispness. I'll try hooking the MacBook up to an external monitor to see if the problem persists.
     
  11. apfhex macrumors 68030

    apfhex

    Joined:
    Aug 8, 2006
    Location:
    Northern California
    #11
    The difference between Camino and Safari can probably be chalked up to the difference between Gecko and Webkit. But as for the rest of the system, it sounds like maybe on your PowerBook you were using different Font Smoothing settings. Indeed, with the "Medium - Best for Flat Panel" setting, OS X does make some text a little more bold than with the other settings.

    From your screenshots, nothing looks wrong. That's how I'm used to anti-aliased text looking in OS X. :confused:
     

Share This Page