Bonjour sleep proxy not working via ethernet

Discussion in 'OS X Mavericks (10.9)' started by solodogg, Oct 8, 2013.

  1. solodogg macrumors 6502

    Joined:
    Oct 28, 2011
    #1
    Hopefully someone else out there has had the same issue i'm currently having, and might be able to help with a resolution, but i'm thinking this might be a bug for Apple to fix.

    After updating my Late 2012 Mac Mini to Mavericks, the bonjour sleep proxy doesn't appear to be able to wake my computer from a sleep state when connected via ethernet. I can enable wifi, and the computer will show up again on my Macbook under shared devices while it's asleep.

    Previously, with Mountain Lion, ethernet worked fine. Actually, before tonight, I have never enabled wireless on my Mac Mini. I have tried to add "darkwake=0" to my boot.plist file with no success, sending WOL packets also refuse to wake the device. I have AirMedia center server loaded on the Mini, and attempting to access via my iPhone and iPad while the Mini is asleep fails. Enabling wifi on the Mini corrected that issue also.

    Any ideas? I'd rather use ethernet than wifi, but this temporary solution will work for the time being if nobody else has any ideas. If this is a bug, I sure hope Apple releases a fix soon!
     
  2. solodogg thread starter macrumors 6502

    Joined:
    Oct 28, 2011
    #2
    http://www.usoftlap.com/t21382.html

    10.9.1 still has the same issue. Still using WiFi just fine, but ethernet with WiFi disabled makes the Mac disappear from the network after going to sleep.
     
  3. to-scho macrumors newbie

    Joined:
    Nov 19, 2013
    #3
    Same problem for me, here is what it solved for me:

    It seems that for whatever reason the Mac tries to use it's own sleep proxy which fails. Since 10.7 you can tell to not use own sleep proxy. He will then use your airport one which seems to work before.

    Edit /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

    Carefully change
    ...
    <key>ProgramArguments</key>
    <array>
    <string>/usr/sbin/mDNSResponder</string>
    </array>
    ...

    to

    ...
    <key>ProgramArguments</key>
    <array>
    <string>/usr/sbin/mDNSResponder</string>
    <string>-UseInternalSleepProxy</string>
    <string>0</string>
    </array>
    ...

    and reboot. According to the link below you must take care for syntax errors and not to leave any ~backup files in the LaunchDaemons folder. For further details have a look here: http://stuartcheshire.org/SleepProxy/
     
  4. kagharaht macrumors 6502a

    Joined:
    Oct 7, 2007
    #4
    Since this is an ongoing problem with Yosemite. Would you know if this fix can be applied to Yosemite?
     

Share This Page