Books.app not seeing ebooks?

Discussion in 'iPod touch Hacks' started by galstaph, Mar 8, 2008.

  1. galstaph macrumors 6502a

    galstaph

    Joined:
    Jul 24, 2002
    Location:
    The Great White North Eh
    #1
    Ok, here is my dilemma, under JB 1.1.2 everything was peachy and my books app could see my ebooks d/l from installer...
    Well, today I got ambitious and upgraded to 1.1.4, ziphone j/b'd it and installed eveything again... now books.app will not see any of the ebooks I install, even its own... :mad:
    I've been messing around for 4 hours on this... any ideas?:confused:

    ps... books.app ver 1.4
     
  2. ElvisThePelvis macrumors member

    ElvisThePelvis

    Joined:
    Oct 14, 2007
  3. mrkramer macrumors 603

    mrkramer

    Joined:
    Jul 11, 2006
    Location:
    Somewhere
    #3
    I'm having this same problem and the ebooks are in the correct location.
     
  4. Tres macrumors regular

    Joined:
    Oct 8, 2007
    #4
    Heaps of people have reported this problem. Books.app needs updating for the newer firmwares. This is the only reason I haven't installed 1.1.3/4 yet.
     
  5. chadtr macrumors newbie

    Joined:
    Mar 3, 2008
    #5
    I'm having this problem on 1.1.1. I've installed and uninstalled every version thats in installer
     
  6. ElvisThePelvis macrumors member

    ElvisThePelvis

    Joined:
    Oct 14, 2007
    #6
    Just put the books in:

    /var/root/Media/EBooks
     
  7. yegon macrumors 68020

    Joined:
    Oct 20, 2007
    #7
    I STILL haven't fixed this problem after 2 months. Can't get it to work again as it always fails to locate my ebooks. The old version I had ages ago worked fine, but I had to go and update didn't I! I thought, after a couple of months, v1.5 may work...but it doesn't.

    Always comes up with the same %$%ing message "/var/mobile/Media/EBooks doesn't appear to exist". GRRRRRRRR! IT DOES! IT DOES %^$£ING EXIST! I've tried every variation ie./var/root/Media/EBooks or mobile (via Cyberduck) but I still phail at life on this issue.

    I'd be eternally grateful for someone to advise as I really miss the app.

    /sobs

    I've tried every version, old, new, BooksJ, they ALL show up the same error. I'm fairly savvy with such things and it really pains me that I still I haven't got it working again after all this time ;_;

    I mainly use a Sony Reader for reading ebooks and manga, but the Touch is a nice pocket sized alternative if I don't want to cart around the (bigger, more fragile) Reader.
     
  8. Teppic macrumors newbie

    Joined:
    Oct 28, 2007
    #8
    I had this problem when I upgraded Books to 1.5-r523. This version looks for the files in /VAR/MOBILE/MEDIA/EBOOKS now. You can place them in this folder or a subfolder of your choice.

    Hope this helps :apple:
     
  9. mykdickson macrumors newbie

    Joined:
    Jul 17, 2008
    #9
    fixed mine

    Hi,

    Hope this helps

    I also had problems with the Books ver 1.5-r523...whenever i opened it, it showed access denied...and that i didn't have enough access rights to /var/mobile/media/ebooks...

    Using winscp, i went to /var/mobile/Media and right click on EBooks and clicked on properties for the folder...in the permissions section, I ticked on all Rs, all Xs, and the W on owner. i can now access my ebooks just like before...
     

    Attached Files:

Share This Page