Boot Camp 1.3, Vista and Apple Wireless Keyboard

Discussion in 'Windows, Linux & Others on the Mac' started by mags631, Jun 16, 2007.

  1. mags631 Guest

    Joined:
    Mar 6, 2007
    #1
    I am running Vista Ultimate on MBP 2.4GHz. Yesterday, I bought an Apple Wireless Keyboard to use while the MBP sits on my Griffin Elevator. I also have a small logitech bluetooth mouse that I had been using with my PC laptop.

    While the logitech BT mouse had no issues pairing in Vista, I did experience two issues with the Apple keyboard. Here is how I addressed each issue (in Vista):

    1. Bluetooth properties window disappears before I can enter a passkey into the keyboard. Frustrating because you must have a passkey for the keyboard to work. Fix: removed all my BT devices and added the Apple keyboard first. This time it let me type in the passkey and pair. Then I added the mouse, which obviously doesn't require a passkey.

    2. When rebooting into Vista after using Mac OS X, the BT keyboard is no longer paired and no longer shows up in the BT wizard. This has happened twice this morning. Fix: turn off the Apple keyboard (switch is on the back) for a few seconds, turn it back on and re-search. You will need to repair the device. Annoying, but at least it pairs!

    Please post any other lessons learned here!

    Apologies if this post duplicates another -- a forum search didn't turn up anything obvious.
     
  2. stadidas macrumors regular

    Joined:
    Feb 27, 2006
    Location:
    Kent, United Kingdom
    #2
    I have XP, but this may work.

    What I do is when Windows is booting, I turn the keyboard and mouse off. When Windows has booted up, switch them back on. It should re-pair by itself after about 10-15 seconds.
     
  3. gadgetgirl85 macrumors 68040

    gadgetgirl85

    Joined:
    Mar 24, 2006
  4. zauriel macrumors member

    zauriel

    Joined:
    Apr 28, 2007
    Location:
    Nixa, MO
    #4
    mags, let me ask you this ... do you ever face the problem of when rebooting from Vista, and you need to reboot back into Vista and not OS X, that when you hold down the option key, it fails to bring up the startup disk screen where you can select Windows, but instead boots right into OS X?

    I've had this problem with every version of Boot Camp so far. If restarting from OS X, it reads the option key fine and takes me to the selection screen. But if I reboot from Vista, it's like it doesn't read the keyboard at all and so loads OS X since that is my startup disk by default. I know you can change the startup disk to boot from, but I shouldn't have to.

    But yes, I've encountered both of the problems you mentioned. The first was an easy workaround. The second I wouldn't consider "figured out" really. The fact that you have to turn the keyboard off and then on again is cumbersome, especially when I don't have to do that for the mouse (I just have to click it, and it's automatically recognized). Every time, off then on, then I tap the Caps Lock key until I see the light turn green. That's how I know I'm connected. I'm really hoping Apple has fixes this with Leopard. I was hoping it would be with 1.3, but no dice.
     
  5. mags631 thread starter Guest

    Joined:
    Mar 6, 2007
    #5
    Yes, this seems to work! Thanks for the tip.
     
  6. mags631 thread starter Guest

    Joined:
    Mar 6, 2007
    #6
    Confirmed -- this just happened to me.

    Agreed -- I would like this issue to be addressed by Apple. I was mostly concerned about finding any "solution" (even a workaround) and a few searches didn't yield useful information other than a post on the Apple forums that said that the Apple Wireless Keyboard doesn't work in Vista.

    Exactly -- I've been doing that as well.

    Agreed.
     

Share This Page