Boot Camp 3.0 Drivers missing for Windows 7.

Discussion in 'Windows, Linux & Others on the Mac' started by Boesky, Sep 6, 2009.

  1. Boesky macrumors 6502

    Jul 16, 2009
    I just installed Windows 7 on my MBP. When I inserted my SL disc, I did not see an option for Boot Camp. All I saw were two things asking about Remote Mac OS X install and some Disc sharing. Something as if my MBP was a MacBook Air.

  2. Steve1496 macrumors 6502a


    Apr 21, 2004
    You have to go to My Computer then explore the Boot Camp CD. Find setup or something similar in there and double click it. This will launch the driver installation wizard and should install everything correctly.

  3. SomeSwede macrumors member

    Feb 26, 2009
    Land of ice and snow.
    In the start menu, type "cmd", right click it and run as administrator. Navigate in DOS to your D drive, navigate to the folder with the bootcamp files and type BootCamp64.msi

    That should work.
  4. Stridder44 macrumors 68040


    Mar 24, 2003
    For whatever reason the installer doesn't auto-start up when inserting the Snow Leopard DVD. Go to My Computer --> right-click the S.L. DVD --> select Open --> and then open the Boot Camp folder and the installer should be BootCampInstaller.exe should be there.
  5. dkeninitz macrumors regular

    Feb 16, 2003
    Germantown, MD
    The drivers aren't supported on early Intel Mac's if you're using 64-bit Windows, which is why you don't see the option to install them when you insert your Snow Leopard CD. If you try to navigate to the installer via Win Explorer and then start it, you'll get an error message indicating the drivers aren't supported, and they won't install. You need to use the command line method outlined above (and I think you have to run it as an administrator). I believe you can also do an EFI firmware update on your Mac, and then the driver installation routine will show up when you insert your Snow Leopard disk.
  6. phatcat macrumors regular

    Feb 10, 2008
    I had to right click on the bootcamp64.msi file and select some compatibilty mode to get it to run. Works fine on my air.

Share This Page