Boot Camp Assistant cannot be used: You must update your computer's boot ROM firmware

Discussion in 'Windows, Linux & Others on the Mac' started by PsychoLamb, May 9, 2007.

  1. PsychoLamb macrumors newbie

    Joined:
    Aug 21, 2006
    #1
    "Boot Camp Assistant cannot be used: You must update your computer's boot ROM firmware before using this setup assistant"."

    That's the dreaded message I get every time I try to use boot camp 1.2. Unfortunately my firmware is already updated, and any attempt at updating my firmware (again) results in the message that I "don't have to update my firmware."

    I've google'd this problem numerous times, but I have yet to find a solution. Any ideas?

    I'm using a MacBook 13inch, dual-core Intel processor.
     
  2. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #2
    Macbook Pro right? Also is it a Core Duo one or a Core 2 Duo one?
     
  3. PsychoLamb thread starter macrumors newbie

    Joined:
    Aug 21, 2006
    #3
    Nope, just a MacBook. Not a pro. And it's using the core-dual processor.
     
  4. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #4
    Core Duo or Core 2 Duo?

    I remember the original Core Duo machines needing a separate firmware update for Boot Camp and then the Late 2006 firmware update came out as well.
     
  5. Edge100 macrumors 68000

    Joined:
    May 14, 2002
    Location:
    Where am I???
    #5
    How did you score a MacBook with a 15" display?
     
  6. PsychoLamb thread starter macrumors newbie

    Joined:
    Aug 21, 2006
    #6
    Hmmm, I seem to have put a typo :p

    Sorry about that, it's actually a 13inch MacBook.
     
  7. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
  8. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #8
  9. PsychoLamb thread starter macrumors newbie

    Joined:
    Aug 21, 2006
    #9
    I've managed to figure out the problem, though no solution. Bootcamp requires "Boot ROM Version: MB11.0061.B03" while my machine is currently using " Boot ROM Version: MB11.0061.B02".

    However, when I go to manually installed the new boot ROM version from the apple site, it tells me "ALERT This computer does not need this update."

    Seems I have a whole new problem now...
     
  10. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #10
    I'd call Apple, tbh you might be able to solve it by editing a .plist file or something, but that might screw up your machine.
     
  11. nick354 macrumors member

    Joined:
    Jul 2, 2008
    #11
    to bring back a dead post, i have the same exact problem. any help?
     
  12. TheManKinahan macrumors newbie

    Joined:
    Feb 16, 2008
    #12
    Me too, not sure why.
     
  13. TheManKinahan macrumors newbie

    Joined:
    Feb 16, 2008
    #13
    Me too, not sure why.
     
  14. nick354 macrumors member

    Joined:
    Jul 2, 2008
  15. calvin006 macrumors newbie

    Joined:
    Aug 7, 2009
    #15
    SOLUTION, finally

    Like many people here and on other forums, I've struggled with this problem for a couple days now. PsychoLamb was right: if you have boot ROM version MB11.0061.B02 then you need to upgrade to MB11.0061.B03 in order to use Boot Camp. You've probably already been to the Macbook EFI upgrade page and downloaded the update. However, if you're running 10.5 you probably got the same message as PsychoLamb: "ALERT This computer does not need this update." That's because this update was originally intended for 10.4 and will not run properly in 10.5.

    I found this out after spending some time on the phone with Apple. The rep suggested I reinstall or boot to 10.4.6 (or later) and then run the update. If it still doesn't run correctly, than he said the logic board may need replacing.

    I have not tried this yet myself, but it seems to make sense. The boot ROM version MB11.0061.B02 is the original firmware that shipped with the first version of Macbooks (which is what I have and I assume everyone else here has, too). These original Macbooks of course came with 10.4 installed. If you updated your firmware before upgrading to 10.5, then there's no issue. If not, you're stuck with this problem.

    Hope that helps someone because I haven't seen any solution to this anywhere else.
     
  16. calvin006 macrumors newbie

    Joined:
    Aug 7, 2009
    #16
    errrr

    So afer getting my machine back to 10.4.6 and running the firmware update, I'm still getting the same message that: "ALERT This computer does not need this update." According to Apple, this means there is something wrong with my logic board. I don't know about all that, but my end user wants to run Windows (and I'm not buying a new logic board) so I'll try to install it without boot camp, which I think is possible...

    I hope the fix that Apple described works for someone else.
     
  17. lunged macrumors newbie

    Joined:
    Sep 11, 2007
    #17
    After upgrading my 2009 Mac Pro to Snow Leopard, I installed the new Bootcamp drivers in my Windows 7 RC partition. Upon restarting, I couldn't boot into windows. I tried running the Bootcamp assistant, but I got this same error message. Anyone else run into this problem with Snow Leopard?
     
  18. jkaanu macrumors newbie

    Joined:
    Jan 18, 2010
    #18
    Although a tad late but I got this problem solved on my 20" Mac.
    Background: Used Boot Camp Assistant to install Windows XP SP3. Worked fine for a 2-3 days. All of a sudden Windows partition was no longer bootable. Mac becomes extremely sluggish and starts hanging at the drop of a button. Boot Camp refuses to start giving the same error as all you guys get. Firmware updates do not install as well.
    Solution: Since my Mac is under warranty I called up the Apple Service Center and asked them to have a look at it. This is what the guy did:
    1. Inserted OSX install DVD in drive.
    2. Started the computer with Command+Option+P+R (PRAM option) and selected the OSX install DVD as startup disk.
    3. Selected Disk Utility from Utilities menu and selected Repair Permissions. He said this is a bit different from the option we use from within an installed OSX.
    4. Restart (I saw a small message- Boot Cache something.....)
    5. He then installs a Performance Update. This one was apparently not shown in Software Updates.
    6. Deletes a few preference files.... I could not see which ones.. but he removed at least 4-5. DO NOT DO THIS on your own.
    7. 2-3 restarts and my mac is up and healthy. Boot Camp runs fine. Dual booting is fine too.

    Reason: Your Windows installation must have had a virus!
    I do not agree with his comment but I preferred not to argue.

    In short, call the service center and let them check out what the real problem is.
     
  19. Johanbjerk macrumors newbie

    Joined:
    Jan 20, 2010
    #19
    I have the same problem

    A few weeks earlier i started my Boot Camp assistant and created a boot camp for Windows 7. I didn't have the cd for Windows 7 then, so just let it go, but now when i have the CD I can't open my Boot Camp Assistant to start the installation.
    I don't know what to do, and I got all the updates you guys were talking about.

    Processor 2.4 GHz Intel Core 2 Duo
    Version 10.6.2

    I hope someone can give me a good piece of advice so I get rid of my problem.
    Thanks :)
     
  20. marcg007 macrumors member

    Joined:
    Jan 28, 2003
    Location:
    Boston area
    #20
    I also have the same problem

    I'm on a 2007 2.8GHz core2duo extreme. Bootcamp worked fine for years and was even able to offload the partition onto an external drive which also worked fine for a long time. Then suddenly a few months ago the external drive stopped being recognized as a startup device. I finally had a chance to try and resolve the issue today. Was not worth time sooner because most of the windows things I use work in Codeweavers Crossover Mac. In any event, today I tried to use boot camp assistant to create a fresh partition so that I could restore my backup and got this same message. I would be grateful for any suggestions or assistance.

    Thanks,

    Marc G
     
  21. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #21
    i'd zap PRAM first and see if that helps, I don't see any way the firmware would have been downgraded, but maybe you can try the firmware update again?

    B
     
  22. natc4 macrumors newbie

    Joined:
    Apr 1, 2010
    #22
    Fix

    Hey guys, this might be a little late for everyone BUT! I had the same problem where boot camp needed the apple software to be "updated" before it could open and start my windows 7 install. I read and read and read the forums and couldn't find anything. I was then poking around in the disk utilities and found out that my drive was not journaled, after ENABLING JOURNALING on my "Macintosh HD" drive, i then did a verify disk, then a repair disk and a restart. I then decided just to try boot camp and see if my nosy poking around trial and error worked, and now i have a windows 7 installed and:D:D ready to go. Just thought i would share, hopefully this helps you guys out before going to spend money on something you dont need.

    PEACE out
     
  23. Joceman macrumors newbie

    Joined:
    Dec 19, 2010
    #23
    This solution works for me !

    I have tried as sugest by the previous poster but step by step to pin point the shortest solution.

    i had the EXACT same problem as everybody on 13" Macbook dual core 2 2.0ghz.

    just switch journaling on

    and it work RIGHT AWAY

    so this might be the quickest solution so far

    good luck
     
  24. Jethryn Freyman macrumors 68020

    Jethryn Freyman

    Joined:
    Aug 9, 2007
    Location:
    Australia
    #24
    After using DiskWarrior to rebuild and replace my directory, then a full defragment of my hard disk, I got a very similar message while running fully up to date Snow Leopard on a 2006 iMac.

    Turning journaling on fixed my problem (not sure when it was turned off...)
     
  25. philrunclimb macrumors newbie

    Joined:
    Jan 5, 2010
    #25
    Boot camp "must update system" ERROR - help please

    Hi

    I am running Snow Leopard (installed six weeks ago on late 2007 macbook).

    As detailed earlier in this thread, when I try to run Boot Camp Assistant, I get an error messagewhich says " boot camp assistant cannot be used.you must update your system software before using this setop assistant".

    I have:
    1- updated all Mac software
    2- checked my firmware version is the most up to date
    MacBook (Late 2007) MacBook3,1 MB31.008E.B02 (EFI 1.2) 1.24f3 (SMC 1.4)
    3- enabled journaling

    STILL getting the problem... any solutions please?

    Phil
     

Share This Page