Boot Camp Assistant not partitioning

Discussion in 'iMac' started by dh2005, Jun 18, 2011.

  1. dh2005 macrumors 6502a

    Joined:
    Jan 25, 2010
    #1
    Hey folks,

    My iMac previously had Windows 7 on it, and never caused a problem. For reasons too long and boring to recount, I had to remove it and revert solely to OS X for a while; and today I decided to put it back on.

    Boot Camp Assistant starts as it should, it asks me to apportion the space (I select one third OS X, two thirds Windows) then I click 'Partition'. It beavers away for a while, the blue bar builds up and up, but when it gets to about 60% of the way along it stops. The drive no longer ticks - the computer doesn't appear to be doing anything - and two or three hours later, it's still no further along.

    I don't know how Macs write to their hard drives but, if it's in a linear and sequential fashion, there shouldn't be anything on that drive beyond the first 200GB. It should be completely clear above that, so I don't see how it could be defragmenting or anything. To invert Steve's favourite phrase, it just doesn't work...

    ... any ideas?

    Cheers,



    DH.
     
  2. dh2005 thread starter macrumors 6502a

    Joined:
    Jan 25, 2010
    #2
    Awwww, God. Really in a mess, now...

    ... I returned to my iMac to discover that it had hung. Couldn't get it to respond even to a mouse-click, so I turned the machine off and restarted.

    You can guess what it's done now, I'll bet... it's apportioned the OS X partition, but the Windows partition is nowhere to be seen. Now, when I run Boot Camp Assistant, I only have a 300GB hard drive!

    [sigh]

    Am I going to have to reformat my drive?
     
  3. dh2005 thread starter macrumors 6502a

    Joined:
    Jan 25, 2010
    #3
    One embarrassed call to Apple Care later, and the missing partition has been recovered. Now, let's see whether Boot Camp Assistant works this time...
     

Share This Page