Boot Camp Assistant Unexpectedly Quits

Discussion in 'Mac Apps and Mac App Store' started by frysek, Oct 31, 2009.

  1. frysek macrumors newbie

    Joined:
    Oct 31, 2009
    #1
    I cannot get Boot Camp Assistant to start for me.

    Every time I open the application I immediately get: "The application Boot Camp Assistant quit unexpectedly"

    I have tried repairing my permissions and restarting several times without any success.

    I am using a Mac Mini about 5 months old and just updated to Snow Leopard.
     
  2. PtaTonic macrumors newbie

    Joined:
    Dec 27, 2009
    #2
    Thats the same problem i have, i tried repairing Disk permissions but still does not work. Anyone know how to get Bootcamp Assistant working?:confused:
     
  3. kainjow Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #3
    It sounds like it's crashing. See if there is a crash report for it inside the ~/Library/Logs/CrashReporter folder. If so, post it here, as it may have some clues.

    Also, open Console (in /Applications/Utilities). Now open Boot Camp Assistant, and when it crashes again, see if Console spits out any messages related to the app, as that may also give more clues.
     
  4. PtaTonic macrumors newbie

    Joined:
    Dec 27, 2009
    #4
    Everytime I try it Relaunch it, it pops back up again.
    Heres the "Problem Details":
    Process: Boot Camp Assistant [428]
    Path: /Applications/Utilities/Boot Camp Assistant.app/Contents/MacOS/Boot Camp Assistant
    Identifier: Boot Camp Assistant
    Version: ??? (???)
    Code Type: X86-64 (Native)
    Parent Process: launchd [99]

    Interval Since Last Report: 210 sec
    Crashes Since Last Report: 3
    Per-App Interval Since Last Report: 0 sec
    Per-App Crashes Since Last Report: 3

    Date/Time: 2010-01-08 12:41:17.915 +0000
    OS Version: Mac OS X 10.5.7 (9J61)
    Report Version: 6
    Anonymous UUID: 48E1F4F1-CEAD-4C11-8694-0F270B7A6A9F

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    Library not loaded: /System/Library/PrivateFrameworks/DiskManagement.framework/Versions/A/DiskManagement
    Referenced from: /Applications/Utilities/Boot Camp Assistant.app/Contents/MacOS/Boot Camp Assistant
    Reason: no suitable image found. Did find:
    /System/Library/PrivateFrameworks/DiskManagement.framework/Versions/A/DiskManagement: no matching architecture in universal wrapper
     
  5. PtaTonic macrumors newbie

    Joined:
    Dec 27, 2009
    #5
    download

    I can try downloading Bootcamp Assistant again, but is there anywhere i can download it back except from the CD?
     
  6. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #6
    Looking at the problem report I see the problem right away. Your Mac OS X installation is corrupted. It's complaining that it cannot load a required library because the loader cannot find the correct architecture to load.
     
  7. PtaTonic macrumors newbie

    Joined:
    Dec 27, 2009
    #7
    So what do I specifically do to fix it? I'm not a pro or anything.
     
  8. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #8
    At this point your best course of action is going to be a reinstall of Mac OS X. If you have Snow Leopard, the correct kind of install will be done for you - there is no choice to make. If you have Leopard or earlier, you'll need to select Archive and Install (checking the Preserve Users and Network Settings box, if it's not already checked), from the options screen in the Mac OS X installer.
     

Share This Page