Boot Camp corrupted OSX.

Discussion in 'Windows, Linux & Others on the Mac' started by thefunkymunky, Apr 6, 2006.

  1. thefunkymunky macrumors 65816

    Feb 24, 2005
    Well. I managed last night to get Boot Camp to partition my HD but it has also corrupted by OSX partition so now I cant boot OSX. Disk utility can't repair the drive nor can running 'fsck' in single-user mode. I am also having trouble installing XP, can't read my CD properly for some reason.

    So right now. I am without my MBP with no OSX and no XP. I'm in work typing this. :mad: :(
  2. bousozoku Moderator emeritus

    Jun 25, 2002
    Gone but not forgotten.
    Good luck with restoring your backup.

    That's the trouble with beta test software--unexpected things happen.
  3. vamp07 macrumors member

    Nov 22, 2005
    Are you sure you did not select the wrong partition when you went to install XP?
  4. crazycat macrumors 65816


    Dec 5, 2005
    I nearly made the same mistake and install Windows on the wrong partition but i did not make the mistake.
  5. IanF0729 macrumors regular


    Dec 3, 2005
    Washington, DC.
    The same thing happened to me...sorta. When I set Boot Camp to give me a 10GB partition and rebooted the only partition that was ever visible again was the Windows Partition. What was odd, though, is that Windows Setup was reading that it had 124GB free to format as NTFS, which was confusing since I have a 250GB HDD, 95GB which was free before Boot Camp and 85GB free to OS X and 10GB free to Windows after Boot Camp afterwards.

    After heeding the warnings on many, I double and triple checked to be sure that I had the partitions all set correctly. I rebooted and helt the option button down to allow me to select a partition to boot into, only Windows was available. The scandal! I also hopelessly checked disk utility on my OS X DVD to see what it said and it said there was no partition at all.

    And after I went through all that work slipstreaming my copy of Windows XP to include SP2...:(

    Instead of spending all night trying to simply fix what happened, I figured it as Beta Testing software + Windows and reformatted and put my system back in order, Boot Camp free. It only took about 90 minutes to get it back to the way it was before I started with this Boot Camp business.

    It did seem easy to use, at least, but I think I'll wait until Leapord comes out and cross my fingers for vitualization or a dual-booting option and leave the beta testing to someone else. :cool:
  6. caveman_uk Guest


    Feb 17, 2003
    Hitchin, Herts, UK
    I think you need to boot from your OS X DVD, nuke everything using the disc utility on the DVD and reinstall.
  7. thefunkymunky thread starter macrumors 65816

    Feb 24, 2005
    I can't restore or boot from my backup I made with SuperDuper! either :( I have tried running the OSX installer and installing on my FireWire drive but the installer says OSX cannot be installed on this drive. I have also tried an Archive and Install but that threw up errors and told me to restart.

    Disk Utility wont repair the drive, nor will fsck.

    Are there any utilities like TechTool pro that work on Intel Macs so I can try and repair the partition?
  8. Gm7Cadd9 macrumors member

    Jul 7, 2005
    This is my same exact problem, same with the numbers to, they are very confusing, but most confusing of all is how only 1 partition shows up on booting the xp disc... even after quitting *before* the format I lost OS X, I am restoring my system from my backup for a third time... 45GBs takes a while....
  9. WordChief macrumors newbie

    Sep 4, 2006
    Same problem... no solution

    I'm a new mac owner, and my problem is this:
    I sucessfully installed WinXP, and was installing the drivers. Halfway through that the installaion failed and then stopped. I tried to restart my computer, thinking I could burn a new driver disk in OSX, but holding the option key doesn't boot OSX. It takes me to a grey/black screen where I am forced to wait while nothing happens. My macbook won't boot from the installation disk either. No combination of keystrokes that I've tried will get my macbook to respond in OSX. My XP portion however, works fine.
    Am I totally screwed?
    Please help.
  10. apfhex macrumors 68030


    Aug 8, 2006
    Northern California
    You tried an Erase And Install? Did you try formatting the disk with Disk Utility from the OS X install disk first? Are you sure you drive isn't actually broken? (you said you had a backup, so I figured formatting the drive wouldn't be a problem)
  11. macg4 macrumors 6502a


    Nov 17, 2003
    Des Moines,Iowa
  12. renatomarques macrumors newbie

    Mar 18, 2007
    Worse yet....

    I had a similar problem, WinXP installation crashed, I was unable to eject
    CD from drive.

    Now, I turn on my computer an get only a gray screen. I am unable even
    to Boot with "C", to reinstall OSX. I can hear the drive spinning, the fan working, but only see the gray screen. Same for Windows installation CD.

    When I boot with "D" pressed, I get the question quote, so I think BootCamp did not destroy my video card. (Althought I cannot open the hardware detection tool either)

    Any help???
  13. ivnj macrumors 65816

    Dec 8, 2006
    Ya, I did the same thing. Now I can't even boot so I had to reformat and reinstall. It crashed 1 more time so I had to restart and now it keeps spinning. Might of just not installed it right.

    When I reformat should I use OSX extended Journled or non Journaled.

    What is the correct way to reinstall.

  14. RaMaz09 macrumors newbie


    Mar 21, 2007
    Yeah My XP Got Corrupted, then i ran the cd and accidentally installed XP on my OS X part.

    Jeez that was a bad day for me....:(
  15. Diabhal macrumors newbie

    Apr 14, 2007
    After using bootcamp/windows on my macbook pro for several months, my os X partition suffered a similar fate. My windows partition is fine though, and works as well as ever. I have a copy of Data Recovery 2, but when I try and boot off its disk to get at the info on my os X partition, the machine boots into windows instead. Any ideas on how to make it boot off the disk?


Share This Page