Boot Camp Missing .dll

Discussion in 'macOS' started by anthonyb, Jun 12, 2008.

  1. anthonyb macrumors member

    Joined:
    Aug 14, 2007
    Location:
    Pennsylvania
    #1
    Im currently trying to install Windows XP on my mac but Im having some issues.

    Opened Boot Camp Assistant, followed all the directions, formatted the partition to FAT32, windows unloads files, restarts, then says its missing the wonderful hall.dll.

    No matter what I try, I cant get this to install without it saying that.

    It seems like this problem is somewhat common, but it seems like alot of people are using vm or parallels, so I think my problem is a little different.

    How can I get around this and still be able to install the OS without going through a virtual machine?

    10.5.3
    MBP Intel
     
  2. Anonymous Freak macrumors 601

    Anonymous Freak

    Joined:
    Dec 12, 2002
    Location:
    Cascadia
    #2
    What version of XP are you using? You have to be using XP Home or Professional with Service Pack 2 pre-applied. (Although there are some reports of SP1 discs working fine.) Media Center doesn't install quite right without some tweaking. And "Windows XP Professional x64 Edition" (aka 64-bit XP) also has issues.

    That sounds like the file was corrupt on the install disc, though.
     
  3. anthonyb thread starter macrumors member

    Joined:
    Aug 14, 2007
    Location:
    Pennsylvania
    #3
    I am using xp pro sp2 x86

    I have also tried booting the CD and pressing R for the recovery Console.. in there I have tried 2 different things

    1. expand D:\i386\hal.dl_ C:\windows\system32\dal.dll
    When this executes it says that 0 files were expanded

    2. Attrib -H -R -S C:\Boot.ini
    I get an error when I try and do this.

    Does it matter that when I boot into Recovery mode that the prompt starts at C:\WINDOWS?

    If it does, how do I just get it to say C:\?
     
  4. The Flashing Fi macrumors 6502a

    Joined:
    Sep 23, 2007
    #4
    I have always found that when you're missing the hal.dll, it really is there. The problem is usually a bad boot.ini.

    You said that you had an error when you typed "Attrib -H -R -S C:\Boot.ini." Well. What was the error? It makes it difficult to help you without knowing that.

    Here is everything you should try typing in the recovery console:

    Attrib -H -R -S C:\Boot.ini
    DEL C:\Boot.ini
    BootCfg /Rebuild
    Fixboot

    You should try being at "C:\" instead of "C:\Windows." To change directories, it's the same way in Linux, Unix, and Mac OS X in the terminal. Just type "cd .." to go down one level. So, just type "cd .." to go to "C:\" and then try the above directions.
     
  5. anthonyb thread starter macrumors member

    Joined:
    Aug 14, 2007
    Location:
    Pennsylvania
    #5
    Well folks, I think that I have finally figured out this problem, and the results are shocking. Let me take you through the process.

    After booting into the windows setup from the bcasst you get the screen with all of your disk partitions. Then there is the one labeled BOOTCAMP. Well the instructions say that you need to format the partition to either FAT32 or NTFS well I was highlighting the partition and deleting it, then recreating the partition the old fashioned way. This is what was causing the error.

    What I found out is the correct way to do it, is when you are at the screen, hit enter to insall windows to the partition, that is when it will ask you for what type of partition you want.

    I really cant believe that this one stumped me for as long as it did.

    But thanks for all the help, and hopefully this will help someone in the future.
     
  6. wassit macrumors newbie

    Joined:
    Oct 10, 2008
    #6
    message from the future

    Thanks for posting this. I have had all manner of things happen such broken disk missin hal.dll, all of which made worse by the fact that I have successfully installed XP scores of times. then all of a sudden it stopped working because i had changed the order in which I formatted the disk. Now it works fine. thanks again
     

Share This Page