Boot Camp-Update 3.1 won't install properly

Discussion in 'Windows, Linux & Others on the Mac' started by DaMob, Sep 5, 2010.

  1. DaMob macrumors member

    Joined:
    Dec 28, 2009
    #1
    I've installed the Boot Camp drivers that came with the Snow Leopard dvd.
    Then after everything is installed, I look in the Apple Software Update program for the 3.1 Boot Camp-Update. I try to install this, but during installation several errors pop-up from the bluetooth, trackpad and keyboard driver.

    After restarting the laptop, I can't use the functions (like brightness, volume,...) on the F1-F10 buttons anymore.
    The only solution to make it work again is to reinstall Windows. System Restore or trying to install the original Boot Camp drivers doesn't work.

    I thought this was just some corrupt download so I reinstalled Windows, but the problem still occured. I then did it again, but still...
    So I guess there is another problem.

    Anyone has heard of this problem and knows a solution?

    Thanks in advance!
     
  2. Grannyville7989 macrumors 6502a

    Grannyville7989

    Joined:
    Aug 2, 2010
    #2
    I remember after installing Boot Camp 3.1 drivers onto my Windows 7 partition, via Apple Software Update, it screwed up the colour depth on my display.

    Try downloading the Boot Camp drivers from Apple's website on to your hard drive and run them from there. See if that works for you better.
     
  3. DaMob thread starter macrumors member

    Joined:
    Dec 28, 2009
    #3
    Ok will try that, thanks.

    Is it best to delete the previous drivers before installing the new ones?
     
  4. Grannyville7989 macrumors 6502a

    Grannyville7989

    Joined:
    Aug 2, 2010
    #4
    If you're going from 3.0 to 3.1, then it should update them with no problems.

    If you've still got the problematic 3.1 still in place, I would recommend starting from scratch, reinstall Windows, load the 3.0 drivers and then update from the 3.1 package that you've downloaded from the Apple website.
     
  5. DaMob thread starter macrumors member

    Joined:
    Dec 28, 2009
    #5
    It worked, although there is an issue, but at least the brightness keys and so on still works.

    The issue is that every time I press the brightness key, I can hear my hard disk working (the crackling sound). It doesn't do that with the brightness keys for the keyboard backlight.
    Also when I want to go from the lowest setting to the brightest, it looks like it can't follow. The blocks which represents at which brightness you are, update much slower then at which state the actual brightness is.

    Weird, will probably reinstall and just keep the old drivers, these weren't flawless either, but worked a bit better.
     

Share This Page