Boot Camp won't partition my drive, any alternatives?

Discussion in 'Windows, Linux & Others on the Mac' started by Rho, Mar 15, 2012.

  1. Rho macrumors newbie

    Joined:
    Aug 22, 2011
    #1
    Hey folks.

    Having passed my problems months ago, the Boot Camp Assistant not being able to partition my drive because it was fragmented or something, I now stumble across a similar problem.

    When I run Boot Camp to partition my drive, having gotten past the error of the disk being fragmented (again), it now just doesn't do anything at all. It just sits there for hours, trying to partition my drive, but not progressing.

    Now I was wondering, because God knows I'm about to give up on Boot Camp altogether, is there an alternative way to partition my drive like Boot Camp?
    Maybe, I don't know, Disk Utility? And then using Boot Camp to install Windows?

    I'd very much appreciate an answer, 'cos this is getting on my nerves something fierce.

    Thanks all.
     
  2. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #2
    Yes, you should be able to shrink your OS X partition and create a Windows one using Disk Utility.

    However, I'd recommend doing this instead:

    Create bootable backup using CCC or similar tool.
    Boot from backup.
    Wipe internal disk.
    Restore backup to internal.
    Run BCA again.

    This way you have a backup and can get back to this point.

    B
     
  3. Rho, Mar 15, 2012
    Last edited: Mar 15, 2012

    Rho thread starter macrumors newbie

    Joined:
    Aug 22, 2011
    #3
    Hey there, thanks for the fast response.

    Problem is though, err, how?
    I've no idea what CCC is, and if you're asking me to back-up my Mac, I can't, really. I've no external harddrive that's large enough to back it up, nor do I have a time machine or whatnot.

    The first option sounds good, but I can't find a way to do it in Disk Utility, and then collaborating with BCA to turn the new partition into a Windows-one, without knowing if I'm destroying my Mac.

    So if it's not too much time, could you explain how to do it via Disk Utility & BCA? I've Googled it, but I can't find any results, only the same questions.

    Thanks again.


    EDIT: Nevermind, it worked for no particular reason, with nothing changed, on attempt 4. Drive's partitioned.
     

Share This Page