Boot Camp XP Install used entire partition [SORTA SOLVED]

Discussion in 'Windows, Linux & Others on the Mac' started by Dontdothat317, Nov 22, 2008.

  1. Dontdothat317 macrumors member

    Joined:
    Mar 29, 2007
    #1
    I'm a newb to Macs but a windows expert to some extent. I'm trying to help a friend get XP running on his 2.5 ghz MBP (the non one piece aluminum one) via Bootcamp. I've got XP installed, and in the process of trying to update it with SP2, I get an error that says I don't have any hard drive space. I checked My Computer and of the 117GB of space that I allocated for this partition using Boot Camp Assistant in OSX, only 8GB was free! I tried to clean up the partition and defrag it, but XP said that the partition did not need to be defragmented and that there was virtually nothing on the partition! I am using the NTFS file system.

    Keep in mind I told Boot Camp Assistant to divide the partitions evenly and nothing else has been installed on XP..

    I don't know if there is a way to manage and view all the partitions of the physical hard disk in OSX. I am looking at the desktop in OSX (or whatever you guys call it) and I can see a drive called "Untitled". I'm assuming this is the windows partition.

    Does anyone know what went wrong or what can be done other than trying to delete the partition and reinstalling windows?
     
  2. Dontdothat317 thread starter macrumors member

    Joined:
    Mar 29, 2007
    #2
    this is seriously confusing.. i just reformatted and reinstalled onto the same partition and it did it again... of 117GB allotted for the partition, only 8 GB remain after installing windows. No drivers, no nothing. Does the partition need to be deleted perhaps? I can't believe no one has seen this before... I have used this very cd to install xp professional on my PC for over 6 years now and have never seen either of the two issues that have popped up with this MBP tonight. Earlier I was getting the NTLDR is missing error but that's taken care of now.

    I'm still hoping someone knows something about Boot Camp that I don't?
     
  3. Dontdothat317 thread starter macrumors member

    Joined:
    Mar 29, 2007
    #3
    The issue was PARTIALLY solved to be honest..

    Here is a summary of the issue and what was done and the end result.

    Issue and Testing:
    I was trying to install Windows XP Corporate (Professional that doesn't need activation) using Boot Camp to an equally divided partition. The first issue encountered was the "NTLDR is missing.. push control alt delete to restart". The solution to this issue was to perform a full format NOT in quick mode.

    After successfully installing Windows XP, it was noted PRIOR to installing anything, over 100GB of the allotted 117GB was used in the Windows XP installation. So I deleted the partition, formatted the drive via Boot Camp and reinstalled Windows XP, just incase something didn't get partitioned or formatted properly, but no success and the same result.

    Finally I decided to format the partition for Boot Camp using OSX's Disk Utility. I proceeded to do this, and successfully got the Windows XP files loaded to the partition, then booted in to OSX to inspect the health of the partition, whereupon it was verified that only 600mb of the 117GB were used. Ok so far so good. Now I tried to reboot back into XP to finish the installation and I get the error "Boot loader is missing". Formatted the drive and started over again..

    Solution:
    I deleted the partition and started from the beginning. The solution was to use WINDOWS VISTA HOME PREMIUM WITH SP1, 64BIT.

    I have it running on my Q9450 Quad core, 4GB DDR2 1066, 160GB HD 10,000 RPM Raptor SATA Drive and Radeon HD 4870. It runs GREAT with no issues.. I figured this would be a real test for the MBP.

    Guess what? It installed (a little slowly) but flawlessly. The OSX install disk 1 provided all of the drivers. All drivers installed in one fell swoop and this MBP runs Vista 64bit better than any laptop I have seen. All the issues are gone and the MBP got a rating of 5.1 in the hardware ratings.. I never follow those anyway.

    So its a partial solution.. but maybe the issue was XP was such an old version, it didn't have any service packs on it.. while Vista Home Premium was new.

    Good Luck to anyone else who has this issue and searches this thread. I was not able to solve the XP issue but running Vista was my solution for AutoCad, Pro Engineer and other scientific applications.
     

Share This Page