Boot disk issues; Non-existent bootcamp causing problems; No key combos work

Discussion in 'Windows, Linux & Others on the Mac' started by QuakeProd, Jun 20, 2014.

  1. QuakeProd macrumors member

    QuakeProd

    Joined:
    May 15, 2010
    Location:
    KC
    #1
    Hello MacRumors members. I have a challenge for you, and would appreciate your help.

    (2011 iMac, 27" 3.4 GHz quad, 4gb RAM)

    Had a friend install bootcamp on their iMac. They said it always booted on the windows side and wouldn't allow any keyboard shortcuts during the startup, other than 'Option.' Upon holding 'Option', it showed a firmware lock. They cant recall using a password and apparently there wasn't any other way to switch to the OSX side.

    By the time they notified me to help, I kept running into freezing and Windows constantly needing to repair itself along with no way to choose an OS. I couldn't get into any type of recovery or boot into a disk, so I just completely formatted the drive by removing it from the iMac.

    So, a complete format and OSX.9 installation went well, on another computer. Upon placing back in iMac, it ran into the famous 'no bootable device' issue. I ran into a similar issue on another computer (with bootcamp), and my fix was to remove the (PRAM?) battery and it 'reset' the memory of the computer and booted fine. This time it didn't. Upon booting theres a grey screen and no actions, except the switch to the 'no bootable device' part.



    • Tried resetting PRAM/NVRAM - keyboard won't detect anything.
    • Tried other methods such as removal of RAM, unplugging, power button (although thats more for SMC).. still no luck.
    • Removed the battery, still detects a Windows system thats no longer there.
    • Tried hitting 'C' to no avail.
    • Could not log into Single User Mode.
    • Still upon booting and holding ALT, I run into a firmware password.
    • The HD has absolutely no errors and 'appears to be ok' yet it still wont boot; booted from another computer.

    Are there default passwords for the firmware?
    I thought to reinstall windows, and probably would have, but I cant choose a boot drive.


    If you've made it this far, thanks for reading. I try to refrain from writing so much, but I also want to be clear the first time.
     
  2. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #2
    You need to unlock the firmware password, iirc you will not be able to reinstall OSX without doing so and unsure if an apple store can unlock it for you, report back
     
  3. QuakeProd thread starter macrumors member

    QuakeProd

    Joined:
    May 15, 2010
    Location:
    KC
    #3
    Thanks for your reply.


    Had the friend take it in and he told me Apple said they could do nothing for him. I figured they could get it done in no time being the iMac still has a warranty....but nope.

    I guess now its time to play a game called crack the firmware code.


    I cant think of any other ways to reset the mind of the computer.
     

Share This Page