Boot disk won't mount?!

Discussion in 'Mac Basics and Help' started by sjcapps, Dec 20, 2008.

  1. sjcapps macrumors newbie

    Joined:
    Dec 20, 2008
    #1
    I have a 13" MacBook running Leopard that has worked fine for a while. However, when I woke up from a nap the other day and woke it up from standby, all the programs started freezing. I rebooted it and it showed the blue screen with the apple on it and the spinning circle down at the bottom for about 10 seconds then shut off. It did this several times after resetting the PRAM etc. I tried putting in the Leopard install disk but it the disk wouldn't mount in order for me to re-install the OS. I don't have an external hard drive or anything of the sort sans an i80-gig iPod. The most I have is a desktop PC running XP. I have quite a few purchased iTunes songs on there as well as other files that I would like to recover. Is there any way to repair the hard drive (unlikely) or at least get my files off it and onto another hard drive?
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    What method did you use to try to boot up to the install disc? Start up with the 'C' key held down? Hold down option and select the dvd? If you can boot up to the disc successfully, don't jump right into the installation, try repairing the disk and its permissions. If nothing you try will allow you past the boot screen, you could try to get the system into FireWire target disk mode, but you'd need another Mac to try and recover data from the drive. You can also use target disk mode to try reinstalling/repairing the OS from another Mac.
     
  3. sjcapps thread starter macrumors newbie

    Joined:
    Dec 20, 2008
    #3
    Yes, I booted from the install disk but the repair disk and repair disk permissions buttons were blurred out so I couldn't click them. I verified the disk and it told me "The volume Macintosh HD needs to repaired" (because apparently I was clueless to this before now......).
     
  4. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #4
    Was that when you had the volume or the actual Macintosh HD selected? The volume is marked by the size of the drive (measured in GB). If you had Macintosh HD selected and are still unable to perform either operation, its time to go into recovery mode, pull off whatever you can from your home folder in Macintosh HD/Users, and then do an archive & install or erase & install on the system. Honestly though, if the disk can't be repaired I'm not sure if an archive & install will resolve the issue.
     
  5. sjcapps thread starter macrumors newbie

    Joined:
    Dec 20, 2008
    #5
    How can I access my MacBook on my PC? I have HFSExplorer on my PC and a USB A male-A male cord to connect the two (though I'm not sure if this is what I need to accomplish this).
     
  6. sjcapps thread starter macrumors newbie

    Joined:
    Dec 20, 2008
    #6
    Also, I just (again) tried putting the install disk in and booting from it, and after going to a few of the different utilities went back to the main screen where previously it had said no version of Mac OSX could be found so it could not install (or reinstall) Leopard; however, now it's showing Macintosh HD available for reinstallation--unfortunately, the disk only has 3.7 MB free now, so it' giving me the option to erase the volume and install a new copy of OS X. If this works, will I be able to recover my data with any other (preferably free) program?

    Also, I have a few internal hard drives in my PC. Would getting an IDE-USB Adapter like this one allow me to mount the disk image and somehow at least retrieve my files, or something?
     
  7. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #7
    Do you have an external hard drive? If so, you can copy your files onto it, but you'll have to do so from the command line. I don't know why the OS X installer doesn't include Finder, but it doesn't. Boot from the installer, then go to the Utilities menu (I think that's what it's called) and open Terminal. Then type:

    cp -v /Volumes/[nameofinternaldrive]/Users /Volumes/[nameofexternaldrive]

    If either of your drive names have spaces in them, you'll have to escape them with backslashes, like so:

    My Hard Drive becomes My\ Hard\ Drive

    It should take quite a while to copy. When it's done, plug the drive into another computer and verify that there is a Users folder on the drive with all of your stuff in it. Once that's taken care of, I'd suggest doing a format (full format, zeroing the drive) and reinstalling from scratch. It's entirely possible that there are bad sectors on the drive causing your problems, which is why I recommend zeroing it out – doing so will deal with your problem.
     

Share This Page