Boot DVD no longer boots...

Discussion in 'Mac Basics and Help' started by brothman, Mar 15, 2011.

  1. brothman macrumors newbie

    Joined:
    Dec 11, 2008
    #1
    Ok, so, recently I installed refit, a boot utility so that I could install Ubuntu alongside macosx... I did this and it was successful. I later tried to reinstall noticed in both bootcamp and Disk Utility that I have like 5 partitions to my harddrive and I cannot resize or delete them.. I removed refit the way the instructions included in refit said to,, but I still coud not change the partitions. So, I tried to boot with my Mac OS X install DVD and just erase everything, so that I could fix this issue. Even though I have booted to this DVD several times in the past (using both 'c' and 'alt' at startup) I can no longer do so.

    Research online has yielded the suggestion to boot with target disk mode, using another computer. The problem with that is, I think that would work, but I do not have another Mac.... I have a windows too, but no other mac.. Any ideas on how to fix this? And/Or why my DVD does not boot anymore?
     
  2. MacForScience macrumors 6502

    MacForScience

    Joined:
    Sep 7, 2010
    Location:
    USA
    #2
    Do you have a back up? (If not post back)

    If yes then I suggest the following:

    Your issue is you screwed with your firmware and now have a boot problem (no surprise). You would not be able to delete partitions on an active drive unless it was using something like Boot Camp. My suggestion would be to pull the drive from the computer and mount on the windows computer as an external volume. Reformat the drive as a FAT volume and the re-install in your mac. Boot from disc and reformat as HFS+ journaled and reinstall everything.

    If you still cannot boot then you need to figure out a way to reset your firmware.

    Cheers
     
  3. brothman thread starter macrumors newbie

    Joined:
    Dec 11, 2008
    #3
    Sorry for the delay... I lost the link to this..

    I do not have a backup already, but I can easily make one.

    But, before it comes to that, you said mounting on Windows could erase/ reformat the computer.. But, before it comes to that.. do I really need to remove the hard drive? Why can't I just start it in Target Disk Mode? Is it not compatible with USB? and since Windows does not come with "Disk Utility", like macs do, what util should I use to reformat the drive?

    And oh, the resetting firmware sounds to me like it would make total sense... But how would I do that?
     
  4. brothman thread starter macrumors newbie

    Joined:
    Dec 11, 2008
    #4
    Solved

    ok, so I finally fixed it, and although I forgot to check this page for the answer, what I did is very similar to what you suggested...

    step 1: I installed Windows 7 onto the mbp... That is reformatting as FAT32.. because Windows 7 requires that format for installation.. at least in a standard install....

    step 2: I installed Mac OS 10.6 off of the DVD that came with the computer (Yes, I found it.. Seems like you REALLY need that DVD to reinstall mac.. there are probably other ways, I'm just saying what worked for me)

    step 3: that was it, two steps. By the way, I had windows 7 totally installed and working fine on the mbp before... just needed some drivers to run more smoothly.. but I am sure those are available, some even on the install DVD (the bootcamp drivers)
     
  5. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #5

    It seems that your problem is from trying to boot with a disk that didn't come with your computer?
     

Share This Page