Boot Failure Intel iMac (2007) OSX 10.6

Discussion in 'iMac' started by Androu, Jun 21, 2010.

  1. Androu macrumors newbie

    Joined:
    Jul 6, 2009
    #1
    I know this is a fairly common subject matter but I have tried just about everything suggested but with no success. detailed below are my findings, I was wondering if anyone better qualified than me could suggest a diagnosis?

    What does it do?
    I hear the fans and hard drive and see the white/grey boot screen with the apple logo and spinning cog. The cog will spin for anything from 5 - 30 seconds before freezing. Some disk activity will continue for a short time afterwards before everything grinds to a halt?

    I have tried:

    1. SMC reset - Done, no change to symptoms.

    2. PRAM reset - Done, no change to symptoms

    3. Safe boot - Attempted, progress bar appears and fills but still will not boot with same result, white/grey screen, apple logo and spinning cog for up to 30 seconds before freezing.

    4. Hardware test - Extended Test completed. 13mins 19secs - no trouble found. When rebooting aftert test usual sequence followed but no freezing of spinning cog. Continued to spin for 10 mins with no change......

    5. Boot from install disk - Attempted to boot from OS X instal disk but experience the same sytmptoms as a regular boot. Grey/white screen, Apple logo and spinning cog. Lots of activity from CD Drive, maybe 60 secods, then freezes.

    6. "Repair" OS X - unable to complete, cannot boot as above

    Additionally, I have been able to undertake the following

    Single User Mode and run fsck. Run 1st time, issue resolved. Run 2nd time, disk appears OK. type exit to boot and boot process starts. Systems hangs on following line of text:

    Waiting for window server before finishing bluetooth setup

    Verbose Mode - will boot and runs some diagnostics. I am not knowledgeable enough to interpret the output here but this line stands out as possible issues??

    Bug: launchctl: Please convert the following to launchd: /etc/mach_init.d/dashboardadvisoryd.plist


    I think that covers everything I have tried to date. Is there any more I can do from Single User Mode to resolve the issue? are there any other boot methods I can try?

    Thanks in advance for any assistance.
     
  2. Androu thread starter macrumors newbie

    Joined:
    Jul 6, 2009
    #2
    Lots of views but no response.......

    I guess I should assume the worst and it's time to replace my hard disk.....again?

    It was only replaced 12 months ago and I would have hoped there might have been an alternative solution.
     
  3. Androu thread starter macrumors newbie

    Joined:
    Jul 6, 2009
    #3
    Update

    OK....I have now replaced my HD with a new WD drive of the same specification.

    Upon booting and holding down the option key I now only see the option of booting from Install Disk, which I assume is correct due to the fact the new drive is empty and as yet to be formatted.

    So...I attempt to boot from Install disk and I still have the same problem. It will not boot, just freezes after about 45 seconds of disk activity.:confused:

    I have no tried this with both the new Snow Leopard Install disk and the original install disk that shipped with the machine.

    I have also replaced additional RAM with original RAM that shipped.

    Any suggestions....? I am now at a loss to understand where the problem could be?

    As an aside, I also had a new logic board installed around 6 months ago following damage caused by a power surge so I would hope there is no issue witht hat.

    Any help would now be greatfully recieved.......
     
  4. linkycat macrumors member

    Joined:
    Aug 2, 2008
    #4
    I have no real technical answer for you... But I had the same issue with my 2007 iMac. It turned out I had a bad power supply or power converter... Had to have that replaced and then it worked. Same symptom though with the freezing on boot.
     
  5. Androu thread starter macrumors newbie

    Joined:
    Jul 6, 2009
    #5
    Thanks for the suggestion, in light of nothing else being obvious it certainly is a possibility. However, I have been able to run Apple Hardware Test and this has reported no issues....I am not sure how thorough this or if it might include power supplies?
     

Share This Page