Boot from external

Discussion in 'iMac' started by phifer8390, Oct 12, 2008.

  1. phifer8390 macrumors member

    Jul 11, 2008
    I am trying to boot from my external hard drive and I cannot get the option to show what disk to boot from when starting up. I am using a standard windows keyboard on my iMac G4 right now because I don't have an apple keyboard. Any ideas? I have tried alt, ctrl, alt+windows+shift+delete.
  2. spinnerlys Guest


    Sep 7, 2008
    forlod bygningen
    Are you still able to boot from the internal drive?

    If so, go to System Preferences > Startup Disk and choose your drive to boot from. If it doesn't show up, the it isn't bootable on your machine.

    The following is from TUAW:

    X during startup - Force Mac OS X startup

    option - (eventually) brings up a screen with startup volume choices

    Option-Command-Shift-Delete - Bypass primary startup volume and seek a different startup volume (such as a CD or external disk)

    C - Start up from a CD that has a system folder

    N - Attempt to start up from a compatible network server (NetBoot)

    T - Start up in FireWire Target Disk mode (very handy for plugging your Mac into another as an external hard drive)

    Shift - start up in Safe Boot mode and temporarily disable login items and non-essential kernel extension files (Mac OS X 10.2 and later)

    Command-V - Start up in Verbose mode.

    Command-S - Start up in Single-User mode

    cmd-opt-p-r - Zap PRAM. Hold down until second chime.

    cmd-opt-n-v - Clear NV RAM. Similar to reset-all in Open Firmware.

    cmd-opt-o-f - Boot into open firmware

    hold mouse click - force eject a CD/DVD

    The Alt key should be the Option key, which is generally used to bring up the OS Selection Menu - even when there is only one system to boot from.
  3. phifer8390 thread starter macrumors member

    Jul 11, 2008
    Thanks for that. Soon after I realized that my iMac G4 will not boot from an external USB drive only firewire. I finally got the drive menu when I plugged the keyboard straight into the computer instead of into my USB hub.

Share This Page