Boot mini bug !!!

ggkameleon

macrumors newbie
Original poster
Nov 20, 2014
12
0
hi ! I have buy a new mac mini 2012 with Hd 500 and I have a mini 2009 with SSd 500.
I put the Ssd in the mini 2012 and the Hd in the 2009.

The mini 2012 run good. But no the mini 2009 when I start "boot" don't have the Apple logo and progress bar in grey screen but just black screen and go to my session with password?

I reset smc and pram but nothing ? I make an Hard test but nothing !?

I don't know what is the problem ? Can help me please !!

I know is the Efi Firmware is not good. I download in Apple support but say it's not necessary in your computer ??? Perhaps the problem come I have install before change SSD to HD in my mini core2duo 2009 the soft "kernel startup 42/64" ? But I don't know reset "boot.efi" perhaps don't see when start ? Thank's for help
 

ggkameleon

macrumors newbie
Original poster
Nov 20, 2014
12
0
Yes before change I have install Yosemite in two mac mini and after with "Diskmaker" create in the mini 2012 I have install Yosemite to. I see this https://support.apple.com/fr-fr/HT204156
Me I have one bong picture one but stay black screen and go picture Six !!! I suppose the rom or Efi boot ?
I reset smc and pram but nothing do !!!!
Sorry for my langage I'm french...
 

Celerondon

macrumors 6502a
Oct 17, 2013
679
123
Southern Cal
You are fine. My French is not nearly as good as your English. By "picture Six" do you mean the one listed as a Login Window? (Fenetre d'ouverture de session).

Also I must ask:
Did you mean "kernel startup 42/64" or was it 32/64 instead?
 
Last edited:

Fishrrman

macrumors P6
Feb 20, 2009
17,200
5,544
What I would do:

1. Boot 2009 Mini from external source (external hard drive), or connect it to 2012 Mini using firewire target disk mode.

2. Re-initialize internal hard drive.

3. Re-install clean copy of OS -- already downloaded from either Apple or another source.
 

ggkameleon

macrumors newbie
Original poster
Nov 20, 2014
12
0
Hi ! Yes the soft "kernel startup 32/64" I is deleted.

I make this :
I download Yosémite in the App store in my mini 2009 and I create a Usb key of Yosémite with Diskmaker.
I make a clean install and erase my Hd system.
My mini boot good ! Apple logo and progress bar and the screen resolution is back to normal 1024x1080.

But 2 days after when I shoot down and restart the screen resolution bug again 1024x768 and I can't change this in preference ? I reset smc and pram again and the boot again black screen no logo and progress bar !?

I just buy a mini dvi to vga I stay shipp for see if is not the connector mini display ?

Yesterday I restart with my usb key (install Yosémite) and don't install just shut down.
When I restart the green screen logo and progress bar and I can change the resolution 1024x1080 ??? I don't understand what is the problem ???

Do you know if is it the battery ? I buy one cr2032 I stay shipp ??? Maybe ? Thank's