Boot problem disk0 (HDD Works on other mac)

Discussion in 'MacBook Pro' started by HesselCuracao, Feb 14, 2016.

  1. HesselCuracao macrumors newbie

    HesselCuracao

    Joined:
    Feb 14, 2016
    #1
    Hello,



    My macbook 13" 2012 wont boot anymore. It gives the icon with the question symbol. So first of all I did some research and maybe the hard drive could be dead.

    I opend my 15" macbook pro early 2011 and put the mbp 13 inch hdd in my 15 inch model. The mac boots perfectly so that means the hdd from the 13inch is not dead and working propely.

    So what I did. I putted the 15" SSD in the 13" model. And gues, the macbook 13" boots perfectly so the SATA cable is also working and all other hardware is working good.

    So It's realy strange why the hdd wont boot because the hdd is working perfectly on my 15" model and my SSD is also working on the 13" model...


    I opend internet recovery (cmd R) and opend terminal and did the following tag

    diskutil list

    A lot of disks but all are small size and the Mac OS Main Disk is about 1.9 gb...
    So the hack why it is working perfect on my 15" and not on the 13"?

    I think the mac doenst know how to boot or something..
    I'm out of ideas and hope someone can help me further.

    Thanks and gratefull

    Hessel
     
  2. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #2
    It may have been a one-time problem on the 2012 MBP (have you put the disk back in the 2012 MBP?). You should also go into Disk Utility and see what the SMART status is. Maybe the disk is starting to fail. You can also try running the Apple Hardware Test.

    I don't understand the following.

    Do you mean 1.9 TB? 1.9 GB would be very small and also doesn't match the size of the Recovery or EFI partitions.
     
  3. HesselCuracao thread starter macrumors newbie

    HesselCuracao

    Joined:
    Feb 14, 2016
    #3
    It says the Main MacOS System is about 1.9 GB... Very strange because the HDD works perfectly in my older 2011 type.
    Did the hardware test and passed it. I will check smart status today but I don't think this works..
     
  4. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #4
    I'm wondering if your 2012 MBP is seeing other drives. If you press the option key while booting, you should see your HDD and the recovery partition (unless you don't have one). Do you get the same result by selecting the hard drive that way and trying to boot?

    If that doesn't work, you can try resetting the NVRAM and SMC.

    https://support.apple.com/en-us/HT204063

    https://support.apple.com/en-us/HT201295

    I don't think partition-specific information is stored in either but because there seems to be something specific to the 2012 MBP happening, it's worth a try.

    Do you still have the DVD drive in the MBP? If you've replaced it with an HDD or SSD you can try switching them around to see what difference that makes.

    If you haven't already, you can also try booting into the recovery partition, if you have one or the Internet recovery and try running the repair disk there.
     
  5. HesselCuracao thread starter macrumors newbie

    HesselCuracao

    Joined:
    Feb 14, 2016
    #5
    Yeah I know it is really strange. My 2011 mbp has only a SSD in it.
    I tried SMC and PVRAM reset but nothing helped so far.

    I cant understand why my mbp 2011 starting up whitout problems and if I use the hdd in the mbp 2012 nothing works and I get a error.

    I will try some things after work, otherwise I back up all the stuff and do a HDD format and a fresh OSX install. I think that is the last option.
     
  6. tylamb19, Feb 15, 2016
    Last edited: Feb 15, 2016

    tylamb19 macrumors member

    Joined:
    Dec 27, 2014
    #6
    I think I might know what's wrong. The 2010-2012 era cMBPs have a design flaw that causes their HDD cable to fail after a while. I work at a school district where teachers use these 2010-2012 MBPs and almost all of them have done exactly what you are talking about (flashing "?" but the HDD works in other machines). The cable would be my bet. Unfortunately, the flaw does not have a replacement program, so you will have to do it yourself. It's not that hard, though.

    EDIT: Here's a link to the process. Parts are available on iFixit too.
    https://www.ifixit.com/Guide/MacBook+Pro+13-Inch+Unibody+Mid+2012+Hard+Drive+Cable+Replacement/10379
     

Share This Page