Boot Problems DIY Fusion Drive

Discussion in 'MacBook Pro' started by DirkOrnee, Sep 14, 2015.

  1. DirkOrnee macrumors newbie

    Joined:
    Sep 14, 2015
    #1
    Hi there,

    Recently I installed a WD Black 2 dual drive in my early 2011 Macbook Pro. I've managed to make a fusion drive out of it, and it's doing everything I expected from it. The only problem is that intermittently, my mac won't boot all the way. It will get stuck at the loading screen you get after the apple logo. I've tried waiting it out (for like 2 hours), but that didn't do anything. I've done all the standard stuff you can think of; resetting pram/nvram, smc, fixing stuff in disk utility, etc. I've also enabled TRIM successfully, in case some of you are wondering.

    I've booted in Single User Mode and ran the /sbin/fsck -fy command, which gave me the log in the picture. So clearly something is going wrong at the end of the log. Does anybody have a clue what the problem is and what I can do about it? It's hard to pin down for me because it's so inconsistent (it's hard anyway, since I don't have any serious computer training).

    I'm running a 4 core intel i7 @ 2 GHz, 8 gigs of RAM (1333 mhz I think) and an AMD Radeon HD 6490 265 MB gpu.

    Thanks for any help in advance!!
     

    Attached Files:

  2. DirkOrnee thread starter macrumors newbie

    Joined:
    Sep 14, 2015
    #3
    I followed the exact instructions, step by step and thus installed the latest firmware for the drive. So installation can't be the problem. I'm thinking since I cloned my complete drive (so not a clean install), maybe something is just a little bit messed up. I couldn't get TRIM on at first, but got some lines of code from the creator of TRIM enabler, which fixed it. I'm hoping something like that exists for this boot problem.

    Thanks for your help!

    D.
     
  3. duervo macrumors 68000

    duervo

    Joined:
    Feb 5, 2011
    #4
    I would back it up if you can get it booted and then reinstall. Test it out for a few days then, before restoring the backup.
     

Share This Page