Boot Problems with Yosemite

Discussion in 'iMac' started by Cantaloupe, Jun 3, 2015.

  1. Cantaloupe macrumors newbie

    Cantaloupe

    Joined:
    Jun 3, 2015
    #1
    Hello,


    Got the latest version of Yosemite running on an early 2008 iMac. Not ideal but chugs along okay. Kids use it mainly.

    Had some problems recently that I can't seem to solve and need some advice and help with.

    The computer allegedly had a healthy shut down (not forced or plug pulled out of the wall) and then the next time a boot attempt was made, the progress bar would make it about 40% of the way then go to a grey screen with the cursor visible. It would be stuck like this and not do anything from here on.

    At this point I did all sorts:
    • Recovery mode Disk Utility, permissions and disk repair. Came back fine. I did fsck multiple times in single user mode after this.
    • Tried to boot into safe mode; it'd just get stuck at 40% and do nothing.
    • Cleared NVRAM
    • Boot into recovery, turn off wireless, then restart unit
    No luck. Nothing worked. I then tried verbose boot, monitored what was happening. Let me paraphrase some of the errors in no particular order:
    • disk0s2 warning; something like diskarbs not working, as well as NO WRITE appearing
    • Complaints about the bootplaylist directory not existing, as well as something like install_cleanup. I think the directories stated were /var/db/
    • Keeps saying it needs to rebuild an apple kext to do with the kernal or a cache, I think it shows //System/Library/****** (yes, two //)
    • Makes an exception for something called JMicronAta kext
    I deleted a bunch of files in single-user mode. The bootplaylist / kext, the boot cache directory. I ran a check of the update_dyld_share_cache and it didn't exist, and refused to create it. Don't know much about what that means. Disk verified again, then tried to boot. Didn't help.

    I have a Bootcamp partition created pre-Yosemite. I booted into it (XP) and backed up files from my OS X partition, then I went back into recovery and reinstalled OS X (not a clean install, just patching over).

    After it was done it booted up fine, I logged in and it seemed all clean. I was going to tweak the startup services settings and turn off filevault, but I forgot. When I restarted the computer, a new issue happened and I haven't been able to solve it.

    It gets to about 40%, then a white spinning loading bar appears over the progress bar. The Apple logo / progress bar usually disappear for a second before this happens. It goes to a black screen. The cursor appears for a few seconds, followed by the white spinner appearing again, and then the cursor disappearing. It does this on a loop, I left it for about 30 minutes then turned it off. Ran fsck again, tried clearing the NVRAM again, restarted a few extra times. It's stuck there.

    Advice for what to do next? Starting to suspect something is wrong on the hardware side, although all seemed well in the Bootcamp XP partition.


    Thanks in advance.
     
  2. Cantaloupe thread starter macrumors newbie

    Cantaloupe

    Joined:
    Jun 3, 2015
    #2
    Tried again with the reinstall, and then changed some settings (mainly startup services) to see if that'd help. No luck.

    Backed up files, erased, and installed clean. Issue is fixed and the old thing runs much smoother now, I don't think it's ever had a clean install since it came shipped with Leopard.

    Unsure of cause of failure; something corrupt with the boot process.

    If anyone has had a similar issue and can share a solution that doesn't involve a clean install, please share in case anyone else needs help.
     

Share This Page