Bootable FREEDOS usb stick?

Discussion in 'Mac Pro' started by toke lahti, Aug 18, 2014.

  1. toke lahti macrumors 68020

    Joined:
    Apr 23, 2007
    Location:
    Helsinki, Finland
    #1
    Hi,
    I'd like to flash my 5770 and netkas' instructions include "burn boot cd and make fat partition to hdd". I wouldn't like to mess my hdd's just for one-time flashing of gnu card.
    Sooo, I have tried to make bootable usb stick to my MP1.1.
    I have followed many instructions, made mgr partition, set it active with fdisk, tried few images and few different sticks. No success so far.

    Just wondering why this is so hard? Is there anywhere a simple detailed list of what is needed for usb stick to boot with MP1,1.
    It is possible (even some have said otherwise), I've installed 10.9 to my MP1,1 with SFOTT from bootable usb stick.
    Is this just hardware crankiness or what?
     
  2. Graeme43 macrumors 6502a

    Graeme43

    Joined:
    Sep 11, 2006
    Location:
    Great Britain (Glasgow)
    #2
    I have a 1,1 and don't think its possible to boot anything other than Mac OS X from USB :apple:

    Anything that uses legacy mode such as windows wont show up as bootable from USB
     
  3. toke lahti thread starter macrumors 68020

    Joined:
    Apr 23, 2007
    Location:
    Helsinki, Finland
    #3
    Thanks for the opinion, but it can be done.
    I'm just surprised that there's no straight step-by-step howto anywhere (that I could have found) with overall instructions on how to tune the process for any needs.
    There are these:
    http://www.pyrosoft.co.uk/blog/2013/01/09/creating-a-bootable-usb-stick-from-osx/
    http://www.io101.org/blog/howto/how...ash-drive-memory-stick-for-intel-macbook-pro/
    Former is for howto make boot stick for hp's server with mac and the latter one is howto boot from usb to hdd firmware upgrade image.
    Problem with latter is that the volume is too small for freedom image.

    What I have understood so far:
    MP1,1 can boot from MBR stick if:
    1. First partition is FAT and has syslinux in it
    2. First partition is set "active" in MBR (e.g. with fdisk)
    3. last partition is HFS+ and has rEFIt in it.

    So far I haven't been able to get freedos to boot from second partition. (I made 4 partitions in the usb stick I'm using.)
    Any help anybody?
    Maybe freedos' partition should be fat12 or fat16?
    Or if I could make syslinux partition bigger to fit fdbasecd.iso there. It surely works off the cd, if those other freedos images don't work with MP1,1.

    How could this be done?
    Is it possible to resize mbr partitions?
    I've tried to manually make big fat & hfs+ partitions and copy syslinux' and rEFIt's files to there, marked active and tried to write mbr "sudo dd conv=notrunc bs=440 count=1 if=mbr.bin of=/dev/rdiskX", but then rEFIt doesn't show up in boot options...
     
  4. brand macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #4
    Sounds like you got it all figured out then
     
  5. ScottishCaptain macrumors 6502a

    Joined:
    Oct 4, 2008
    #5
    It can't.

    The firmware on the MacPro1,1 is only capable of booting EFI based operating systems off USB (and support for that is extremely limited). The CSM ("Bootcamp") doesn't understand USB booting at all. Your problem is that how-to guides which use Refit land up loading Bootcamp anyways and trying to point it at the USB device, which doesn't work. And yet FreeDOS requires Bootcamp to operate, so you're stuck in the pickle of trying to boot through Bootcamp when Bootcamp does NOT support USB devices (this isn't a matter of you not doing things right, the support to do this is not present in the firmware).

    Your best bet is to try and create a bootable FreeDOS CD. Bootcamp will happily boot from that on the MacPro1,1. From there you should be able to either mount a second CD containing your flash utility and ROM images (assuming you have two Superdrives), or mount a USB key and run things from there. This is how I had to do it many years ago, after I wasted over a week trying to get the system to boot from USB directly (going so far as to dismantle and disassemble part of the EFI firmware- which is actually based on Insyde H2O).

    -SC
     
  6. mikeboss macrumors 65816

    mikeboss

    Joined:
    Aug 13, 2009
    Location:
    switzerland
    #6
  7. toke lahti thread starter macrumors 68020

    Joined:
    Apr 23, 2007
    Location:
    Helsinki, Finland
    #7
    Thanks for the intel. Btw, you forgot to wish farewell with so used phrase "Go buy a windows box then!"

    I tried to boot with fdbasecd.iso installed in syslinux partition from usb, rEFIt works and I could choose which partition from usb to boot, but then came the errors (again). Lost patience wasting about 10 hours to researching this and wasted few hours more emptying one sata hdd, booting from cd, flashing gpu and copying stuff back to hdd.
    Silly that you have to do all this (if you don't want to endanger your important hdd's) and use about 0,05% of hdd's capacity.
    Strange that you can't boot the same image from usb, that you can boot from cd.
    If there is a way for freedos booted from cd, to see usb (or other storages than internal sata), I'd be interested to know how to do this next time (if I still remember all this then).
    After the hassle, I also noticed, that maybe I could have used some old pata hdd with odd cable or that I have pata-sata adapter, that may have also worked.

    Oh well, now GTX760 and 5770 does not work together so well anymore...
    21" crt connected to 5770 (to see the boot screen) can't use any other resolution than 1280x1024 when not in mirror mode!
     
  8. deconstruct60 macrumors 604

    Joined:
    Mar 10, 2009
    #8
    1. Circa 2005-2006 ( Windows XP era) Microsoft primarily distributed their OS on CDs. Bootcamp (and the associated BIOS emulation) primary purpose was to boot Windows from an internal hard drive as per the mainstream Windows install/run licensing guidelines required. That's it. Bootcamp's (and BIOS) objective is not to be the most well rounded generic PC on the market. It just had to be good enough to get the primary job done.

    The objective never was DOS. At least Windows was going to EFI/UEFI over time. DOS is stuck in the stone ages permanently wedded to BIOS.


    2. Adding the ability to read/drive USB adds complexity to the BIOS. Especially when from the Mac OS X perspective it is redundant.

    As Windows moved to downloadable iso and USB thumb drives got as least as cost effective as CDs then later Mac EFI legacy modes got USB capability.


    Once booted it should be able (presuming reasonable drivers loaded). The blockage is more so abilities at the bootstrapping process when the OS isn't loaded, so therefore there are no USB drivers to talk to. EFI knows how to talk to FW, USB , SATA , SAS , etc. It is the legacy BIOS all by itself that is bit clueless.

    If go back to 2005-2006 era mechanism (e.g., boot from CD) shouldn't have problems with MP 1,1 2005-2006 era limitations. If using a "back in time" machine then equally "back in time" methods typically work better.
     

Share This Page