Bootcamp and disk verifcation failing

Discussion in 'macOS' started by amfr, Jan 19, 2007.

  1. amfr macrumors member

    Nov 24, 2006
    Ok, a couple of days ago I decided to use parallels on my windows bootcamp partition. A bit into the installation of the parallels tools, the program crashed and I killed the process. Since I had been meaning to nuke and re-create the partition anyways, this gave me another excuse as I thought that the partition would be messed up now. 1 thing though, after killing parallels, the windows partition disappeared from my desktop. I opened up the bootcamp assistant and went through the steps to delete the partition. After re-starting, I opened up bootcamp assistant to recreate the partition (a little larger this time). The partitioning failed because "some files could not be moved". So I tried it again, This time, the installer came up with the error "the disk could not be verified" and told me to repair the disk with disk utility. I opened up disk utility and the repair button was disabled, so I pushed verify disk. It came up with and error saying "the process could not be completed" but the output of the verification said that the disk needed to be repaired. But the repair disk button was (and is) disabled. I have restarted multiple times and re-tried everything, but nothing has worked. Anyone have any ideas about any/all of the problems?
  2. apunkrockmonk macrumors 6502a


    Nov 20, 2005
    Rochester, NY
    You can't repair a disk that you're booting off of.

    You have to boot from another hard drive or from your OSX cd to repair the drive.

    When I had this problem disk utility couldn't repair the disk. I had to back up my hard drive with CCC, reformat and then I was good to go.
  3. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    If your OSX discs are not accessible, you can run fsck from Single User Mode. :)
  4. amfr thread starter macrumors member

    Nov 24, 2006
    How do you use the OS X DVDs to repair the disk?
  5. shov macrumors member

    Dec 3, 2006
    i've got a similar problem: bootcamp assistant says it can't partition my disk because the disk can't be verified. i repaired the disk in disk utility and reran bootcamp but i got the same message again.
    any ideas?
  6. zami macrumors regular

    Dec 19, 2003
    South London
    Restart as per install and as as soon as it reboots from the DVD select Disk Utility from the drop-down menu in the menu bar.

Share This Page