Bootcamp and MacOS hard drive moved to optibay after installation

Discussion in 'Windows, Linux & Others on the Mac' started by bryab, Apr 1, 2012.

  1. bryab, Apr 1, 2012
    Last edited: Apr 1, 2012

    bryab macrumors newbie

    Apr 1, 2012
    Hey everyone,

    I had purchased a 128GB Crucial M4 SSD, installed OSX and bootcamp to the SSD and then relocated the drive to the optibay to put my HDD back into the original bay. Now my OSX boots but bootcamp doesnt. Details on how I set it up/other issues I faced but managed to overcome are as follows:

    After reading lots on the best way to proceed with this setup and to minimize the issues of installing Windows from a USB, using rEFIt or an external optical drive, I decided to install both Mac OSX 10.6 and bootcamp to my SSD before relocating it to the Optibay (in a Mid 2009 MBP).

    Before I relocated the SSD to the optibay, I installed all the updates for both Mac OSX and Windows 7 (Ultimate, 64-bit if that matters). I then put my original HDD back into the original HDD bay and had that flashing folder issue. I fixed that by installing rEFIt and removing it. Not sure why this worked but my OSX boots fine however, when I hold alt and select to boot windows, I just get the blinking cursor. I let it sit for a while (more than half an hour, a waste of time, i know) but it still wouldnt boot. I have a theory that it might be because I moved the SSD to the Optibay after installing it and when booting, the machine thinks windows is still installed on the disk in the main bay.

    To be honest, I have no idea how Mac boots and determines where to boot from etc. I dont know how rEFIt works and I think I just lucked out that it now boots into OSX fine. Does anyone have advice on how I can fix the boot thingy so I can access my already-installed-and-work-before-i-moved-the-ssd-to-optibay Windows 7?

    Edit: I just installed VMWare and it's booting fine there.
  2. bryab thread starter macrumors newbie

    Apr 1, 2012
  3. Sincci macrumors regular

    Aug 17, 2011
    Well, Windows doesn't seem to work properly in the optibay for some reason. I had some unexplainable slowdowns when I tried to install Windows into an SSD that was in my MBP's optibay. When I switched it into the mainbay, it worked just great. According to your post, you seem to have same MBP as I do, so perhaps this is exactly the same issue. Unless you have some good reason why you want to keep your HDD in the mainbay, you should just switch the SSD back in the mainbay and keep the HDD in the optibay since that one works just fine for me.
  4. kudukudu, Apr 4, 2012
    Last edited: Apr 4, 2012

    kudukudu macrumors regular

    Oct 24, 2007
    I have more or less the same problem as you. I bought a 128GB crucial M4 about 6 months ago and installed it in bay 3. I used SuperDuper! to clone my OS to the SSD and I left my user directory on my 750GB drive.

    I used to have windows XP running through both bootcamp and vmware off of a dedicated 320GB drive in bay 1 (e.g. nothing else was on this drive except for the windows partition). When I installed the SSD I used bootcamp assistant to create a windows partition on my 1 TB drive and I used winclone to move my windows installation to that partition. Here is a visual of my before and after setup:


    Bay 1 - 320 GB drive running windows/bootcamp
    Bay 2 - 750 GB drive running OS X including home directory
    Bay 3 - 1 TB drive housing data files
    Bay 4 -empty


    Bay 1 - 1 TB drive. Partition 1 with data files, Partition 2 running windows
    Bay 2 - 750 GB drive with data files and home directory
    Bay 3 - 128 GB SSD running OS X
    Bay 4 - 2 TB drive housing data files

    Windows XP boots up no problem for me in vmware, but when I try and boot via bootcamp I get the flashing cursor problem. I haven't tried to boot into bootcamp for quite a while so I am not sure it ever worked after my migration.

    I am stumped as to what the problem is, but I suspect that with all of my migration activities is that OS X has lost the bootcamp partition and I don't know how to go about fixing this.

    Interestingly enough I sill have an older working copy of OS X on my 750 GB drive in bay 2. If I boot OSX using my 750GB drive and I look at startup disks I can see the windows partition, but when I boot from the SSD, I can't see with the windows partition in the list of startup disks. Go figure.
  5. bryab thread starter macrumors newbie

    Apr 1, 2012
    I want to keep the HDD in the main bay to keep the SMS active on that drive.

    Here is what I did exactly:

    Original Setup:
    - 10.6.8 and Windows 7 on HDD since I acquired the macbook

    - take out HDD
    - Install 10.6 - Update
    - Install Bootcamp windows 7 - Update
    - Take out Optical Drive
    - Place SSD into optibay drive
    - Put HDD back into main bay.
    - fix boot issue I described in OP
    - format and partition HDD for HSF+ and NTFS storage.

    Final Setup:
    - SSD in Optibay with OSX booting fine and Bootcamp partition working in VMWare
    - HDD for storage working fine in original HDD bay.

    I would still like to be able to go into bootcamp without VMWare though.
  6. Sincci macrumors regular

    Aug 17, 2011
    Well, then the only solution is to sacrifice the SMS feature and install the HDD in optibay since there's no solution on how to make SSD/HDD working in the optibay perfectly as a boot drive (there are reports that the hibernation and sleep don't work correctly in OSX + my experience of awfully slow reading speeds). This problem doesn't even seem to be related to the chipset that is being used since the same thing also happens in the 2011 models that are equipped with Intel chipsets.
  7. kainjow, May 9, 2012
    Last edited: Jun 4, 2012

    kainjow Moderator emeritus


    Jun 15, 2000
    I have a similar issue, but my Boot Camp partition is installed in the original SATA port, and the optical drive port is its own drive which only holds my home folder. When I boot into Windows I get the blinking cursor. If I remove the drive connected at the optical drive port, or reconnect the optical drive, Windows boots fine.

    Maybe Windows on OS X doesn't like it when there's another internal drive in place of the optical drive?

    Update: apparently the BIOS (?) doesn't like the order of the drives. I swapped them and Windows boots now.

Share This Page