Bootcamp assistant refuses to assist

Discussion in 'Windows, Linux & Others on the Mac' started by zephonic, Mar 16, 2013.

  1. zephonic macrumors 65816

    zephonic

    Joined:
    Feb 7, 2011
    Location:
    greater L.A. area
    #1
    This on my trusty old early 2007 20" iMac (2.16Ghz Core2Duo)-3GBRAM-250GB HD-RadeonX1600(256MB)

    Previously, this machine ran the latest version of OSX Lion.


    I did a full system restore on this machine to pass it on to my son. So restore from original system discs (Tiger), download and install all updates, upgrade to Leopard from DVD, download and install all updates, upgrade to SnowLeopard, download and install all updates. Finished.

    I do not want to upgrade back to Lion yet, because it will not allow me to install WinXP, and Win7 is not supported on this hardware (technically a late 2006, last of the white ones).

    I open Bootcamp Assistant, but when I click continue on the first window, I get this:


    The startup disk cannot be partitioned or restored to a single partition.
    The startup disk must be formatted as a single Mac OS Extended (Journaled) volume or already partitioned by Boot Camp Assistant for installing Windows.



    So I run Disk Utilities, 'Verify Disk', everything checks out, of course the disk is formatted as Mac OS Extended (Journaled). Yet Bootcamp won't let me continue.

    What do I do?


    Hold the ff-ing phone, I start up the computer holding the alt (option) key and I see there is a recovery partition???

    Is that why Bootcamp says the disk is not a single partition?

    My best guess is that when I upgraded this machine to Lion, it automatically created this recovery partition. When I did the system restore I told it to format the internal drive but I guess it did not touch this partition.

    This is hidden in Disk Utilities so cannot be removed.


    I understand Apple feels it needs to protect unwitting users from themselves, but man, why can't I do what I want with my machine?


    So can I somehow get rid of this recovery partition, or do I really need to boot up from an external drive, wipe out the internal disk and start all over?
     
  2. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
    This might be because there is not enough contiguous space on the disk, or as you say the Recovery partition is the problem, this (last) is not a problem on Mountain Lion, it might be because you have an earleir Bootcamp assistant.

    Now, what you can do, you could compact the OS with a program like iDefrag, then repair if repair is needed and try again.
    Or, if you have an external disk with enough space, use Carbon Copy Cloner to clone the disk to that external, then repartition the disk and then startup from the clone and use CCC again to clone the disk back to the internal.
    I thought about using CCC to make an image of the disk to the external but then you don't have a bootable backup to startup from so that does not work.
    I think the second option with CCC is the fastest and you'll get everything back as it was before without the Recovery partition, CCC is free up until 3.4.7.
     
  3. zephonic thread starter macrumors 65816

    zephonic

    Joined:
    Feb 7, 2011
    Location:
    greater L.A. area
    #3
    Thanks for your reply.

    Disk space can't be it. I did a system restore and fresh installs of subsequent OS'es. 220 of 250 GB available.
     
  4. AnaheimAngels macrumors newbie

    Joined:
    Apr 19, 2013
    #4
    Sorry for such late reply, but I think I can help you.

    I got the same exact error, but fixed it. You must make sure your Hard drive has only ONE partition on it ( Your startup disk being the only partition ) and it should work !
     

Share This Page