Bootcamp:Battery good in OSX but appears "dead" in windoze

Discussion in 'MacBook' started by kristenanne77, Nov 23, 2011.

  1. kristenanne77 macrumors regular

    Joined:
    Jul 16, 2009
    #1
    Macbook: Bootcamp setup

    This past week I though I needed a new battery. After leaving it in the charger it would usually run for a few hours on battery power. In windoze xp mode it said the batter was 100 percent , then within a few minutes said the battery needs replacing and shut down. I knew the battery wasn't that old, so i started it in regular OSX mode. It ran for a few hours on battery power which is normal .... so it is not the battery.

    Anybody have any ideas what I would have to do to get it working in battery mode while using windoze xp? (It will work plugged in in this mode)

    thanks
    kristen
     
  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #2
    You may actually have a bad battery. OS X will try to keep running, even if it knows the battery is bad. It's possible that Windows takes the safer route and shuts down.
     
  3. kristenanne77 thread starter macrumors regular

    Joined:
    Jul 16, 2009
    #3
    After I get a full charge, disconnect, and then let it run on battery power:

    Windoze will shut down after about 5 minutes.
    I restart in OSX mode and it runs for a few hours. I don't think it could do that if the battery was dead.

    (If I leave the charger connected, windoze will run fine but I kind of expect that, i am more interested in why it doesn't run on full battery power, where the OSX does)
     
  4. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #4
    Oh, that changes everything. Instead, you may actually have a bad battery. OS X will try to keep running, even if it knows the battery is bad. It's possible that Windows takes the safer route and shuts down.
     

Share This Page