Bootcamp cannot partition HD

Discussion in 'MacBook Pro' started by Radiosuit, Nov 9, 2010.

  1. Radiosuit macrumors newbie

    Joined:
    Sep 1, 2010
    #1
    Hey guys, I'm trying to install Windows 7 on my mac. I'm using bootcamp assistant to try and partition my hard drive, but it gives me an error saying it cannot partition it because of unmovable files or something along those lines. Is there any way to get around it, and if I do use my OSX install disk and run disk utility to repair the drive will my files be deleted?
     
  2. Darrenyo macrumors member

    Joined:
    Nov 5, 2010
    #2
    Do you have any existing partitions? If so remove them through bootcamp.

    Secondly have you installed the latest updates?

    Use Disk utility to repair any errors if the above aren't the problem.

    If none of the three work, format your hard drove and reinstall Mac OS X.

    Maybe wait on some more replies though, might be another way.
     
  3. Mac-key macrumors 6502a

    Joined:
    Apr 1, 2010
    Location:
    Alabama
    #3
    I had the same problem - I had to reformat my entire drive, reinstall my OS and all that jazz.

    I was told on this forum that that was my only option. Try the things that were mentioned in the previous post, BUT more than likely you are going to have to reinstall your OS
     
  4. Radiosuit thread starter macrumors newbie

    Joined:
    Sep 1, 2010
  5. Gr80Likes2Boogi macrumors regular

    Joined:
    Oct 3, 2009
    Location:
    NoHo, CA
    #5
    I just did this whole process about 3 weeks ago.

    First off, you should post (actually, SEARCH) in the Windows on Mac forum. I got some great info there. I also googled a lot.

    Anyway, as far as reinstalling the OS- you still have your install discs, right? If you do, then just back up through time machine, then put the OSX install disc and then reinstall the OS. I have an OSX Leopard install disc, plus the Snow Leopard upgrade disc. Had to install OSX Leopard, DL all the updates, THEN install SL and get all the updates (that took a LONG time)

    Once I was all updated, I went into Boot Camp Assistant to set up a partition (50gb) and went from there! I tried all the other fixes people mentioned, but none worked for me. I had to reinstall and start from scratch. FWIW, migrating everything from my Time Machine backup, while a lengthy process, went smoothly. All my stuff was still there, dock, wallpaper, everything.
     

Share This Page