Bootcamp, can't install Latest emergency patch KB4056892

Discussion in 'Mac Pro' started by Anim, Jan 6, 2018.

  1. Anim macrumors 6502a

    Anim

    Joined:
    Dec 16, 2011
    Location:
    Macclesfield, UK
    #1
    My Windows 10 Bootcamp is refusing to install the latest Windows Update to fix the recent security issues.

    In Windows update it says
    Updates are available.
    • "2018-01 Cumulative Update for Windows 10 Version 1709 for x64 based systems (KB4056892)"
    Status: Awaiting install.

    If I click "install now" the status updates with installing and eventually says "Installing 100%" then it says
    Some update files are missing or have problems. We'll try to download the update again later.
    Error code: (0x80073712)


    ...It keeps failing no matter how many times I try.

    So, I went to MS website and download the patch manually
    http://www.catalog.update.microsoft.com/Search.aspx?q=KB4056892

    This goes through the same process of installing then simply says "Update failed".

    Any ideas how to sort this out please?

    Thanks
    --- Post Merged, Jan 6, 2018 ---
    I also tried this (https://answers.microsoft.com/en-us...problems/5267ad01-cef8-43fd-bfcc-45399cc8cbab)
    • Perform System File Check (SFC)
    Follow the steps:

    a. Press “Windows Key" to open Start menu

    b. Type “cmd” without quotes in the search box.

    c. On the left pane, right click on the “cmd” option and select “Run as Administrator”.

    d. Type ‘sfc /scannow’ without quotes and hit enter.


    • run the System update readiness command. It detects incorrect manifests, cabinets or registry data, it may replace the incorrect data with corrected version available. Follow the steps.
    1. Open Command Prompt as indicated above.
    2. In the Administrator: Command Prompt window, type the following commands. Press Enter key after each command:
    DISM.exe /Online /Cleanup-image /Scanhealth

    DISM.exe /Online /Cleanup-image /Restorehealth

    To close the Administrator: Command prompt window, type Exit, and then press Enter.

    ------
    All ok, update fails still.
    ------

    I then tried this:


    I suggest you to manually reset the Windows Updates Components. Refer to the steps below to reset the Windows Updates Components:

    1. Press Windows Key + X on the keyboard and then select “Command Prompt (Admin)” from the menu.

    2. Stop the BITS, Cryptographic, MSI Installer and the Windows Update Services. To do this, type the following commands at a command prompt. Press the “ENTER” key after you type each command.

    net stop wuauserv

    net stop cryptSvc

    net stop bits

    net stop msiserver

    3. Now rename the SoftwareDistribution and Catroot2 folder. You can do this by typing the following commands in the Command Prompt. Press the “ENTER” key after you type each command.

    ren C:\Windows\SoftwareDistribution SoftwareDistribution.old

    ren C:\Windows\System32\catroot2 Catroot2.old

    4. Now, let’s restart the BITS, Cryptographic, MSI Installer and the Windows Update Services. Type the following commands in the Command Prompt for this. Press the ENTER key after you type each command.

    net start wuauserv

    net start cryptSvc

    net start bits

    net start msiserver

    5. Type Exit in the Command Prompt to close it.

    Now you may try running the Windows Updates and check if the above steps resolve the issue.

    ....Same, update still fails, same error.

    Grrrrr
     
  2. Anim thread starter macrumors 6502a

    Anim

    Joined:
    Dec 16, 2011
    Location:
    Macclesfield, UK
    #2
    Next I tried this:

    1. Click Start button, click settings icon, click Troubleshoot label (4 down on left side) and select Windows Update as the thing to troubleshoot.

    It ran through a process and found 3 errors that it fixed.

    2. Run windows update again.

    Failed. Error code: 0x80073712
     
  3. h9826790 macrumors G5

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #3
    Did you follow the MS support web page's step to solve the 0x80073712 error?
     
  4. pl1984 macrumors 68020

    Joined:
    Oct 31, 2017
    #4
    It appears as if he did as what he described in his post is what the support steps are.

    IME I have never, ever, had a MS support article solve any problem I've ever encountered. IMO Googling an error on Windows is worthless. This is one of my primary gripes with Windows...you see everyone encountering the same problem with so many "solutions" none of which actually work. Hate to say it but it might be faster for him to nuke and re-install.

    OP, I have read that A/V may be interfering with obtaining the update. May want to try disabling any A/V you may have. Long shot but may as well.
     
  5. Anim thread starter macrumors 6502a

    Anim

    Joined:
    Dec 16, 2011
    Location:
    Macclesfield, UK
    #5
    Heya, I have followed all the official MS guides that I found yes. Disabled AV to see if it was that. Tried many other things too. Just gave up in the end and booted back to macOS, All this reminds me why I like osx so much, it just works forever.
     
  6. centurypixel macrumors newbie

    Joined:
    Jan 7, 2018
    #6
    I am running Windows 10 Pro on VMWare Fusion Pro 8.5.8 and KB4056892 is refusing to install. I thought exactly the same thing. I love my Mac!
     
  7. corelle macrumors newbie

    Joined:
    Jan 2, 2008
    #7
    KB4056891 for win10 ver.1703
    KB4056892 for win10 ver.1709
     
  8. ActionableMango macrumors G3

    ActionableMango

    Joined:
    Sep 21, 2010
    #8
    Give it a little time. I've had a few Windows Updates repeatedly refuse to install, but then will mysteriously install just fine a couple of weeks later. In one case I read that Microsoft discovered the first update failed in certain conditions, so there was a new smaller update that changes those conditions first, and then the big older update works the next time it tries.
     
  9. jukkhop macrumors newbie

    Joined:
    Dec 27, 2016
    #9
    Having these same problems for weeks now. On an iMac though. Nothing just seems to work.
     

Share This Page

8 January 6, 2018