BootCamp clock issues

Discussion in 'Windows, Linux & Others on the Mac' started by R.Youden, Jun 15, 2007.

  1. R.Youden macrumors 68020

    R.Youden

    Joined:
    Apr 1, 2005
    #1
    I don't know if anyone else has found this, but when I boot out of Windows and into Mac OSX my clock jumps forward by 1 hour.

    Has anyone else seen this and is there an easy fix?

    Does this have anything to do with British Day Light Savings etc...

    Thanks.
     
  2. azizane macrumors member

    Joined:
    Nov 27, 2006
    #2
    I have the same problem, don't worry you're not alone. Don't know about a fix though
     
  3. MajikalMan macrumors newbie

    Joined:
    Jun 24, 2007
    #3
    My guess is that the two operating systems don't recognize the system clock's settings for time zone. I would wager that the time zone variable is local within the operating system, hence, the setting isn't conserved between Windows and OS X. I am located in Eastern Standard Time (GMT -5) and unsurprisingly, the time is always 5 hrs in advance on my Windows side. Attempting to correct the time manually would be futile since that would change the system clock. This is the solution I found in another forum was the edit the Windows registry at:

    Code:
    HKEY_LOCAL_MACHINE
     SYSTEM
      CurrentControlSet
       Control
        TimeZoneInformation
         RealTimeIsUniversal
    
    and set it to a DValue of 1. I have yet to try this myself so good luck!
     
  4. flopticalcube macrumors G4

    flopticalcube

    Joined:
    Sep 7, 2006
    Location:
    In the velcro closure of America's Hat
    #4
    I can confirm that the above fix does indeed work.

    Thanks, MajikalMan.
     
  5. armani macrumors regular

    Joined:
    Jul 20, 2007
    #5
    I tried it, but I can only go to Time Zone Information and I can not see Real Time Is Universal.
     
  6. flopticalcube macrumors G4

    flopticalcube

    Joined:
    Sep 7, 2006
    Location:
    In the velcro closure of America's Hat
    #6
    You have to add that yourself.
     
  7. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #7
    Add a new DWORD (Edit/New/DWORD value) called RealTimeIsUniversal
     
  8. l'homme macrumors member

    Joined:
    Jun 30, 2006
    #8
    doesn't work for me :S
     
  9. SDAVE macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #9
    Did you set the DValue to 1 afterwards?

    I just tried it and it worked!
     
  10. DeadSirius macrumors member

    Joined:
    Sep 16, 2006
    #10
    I've done this, and it's changed things such that Mac OS X always boots up with the correct time, as does Windows XP. However, after a while Windows sets the time forward by 7 hours. I've tried adjusting the time zone, but it has no effect. I can't keep Windows from setting itself 7 hours early. I live in the PDT zone.
     
  11. pavelbure macrumors 6502a

    Joined:
    Feb 22, 2007
    #11
    mine moves by 4 hours. i will try this and see.
     
  12. pavelbure macrumors 6502a

    Joined:
    Feb 22, 2007
    #12
    i could not edit the registry. i got a "registry editing has been disabled by your administrator" which is funny, i thought i was the administrator of my computer.
     
  13. DeadSirius macrumors member

    Joined:
    Sep 16, 2006
    #13
    Weird... Since booting in OS X seems to correct the startup time for XP, I tried unchecking the XP control box that tells the machine to sync to the internet, so that it would stop setting the clock forward by 7 hours. Yet XP still insists on setting it forward after a few minutes.
     
  14. doofusjim macrumors newbie

    Joined:
    Jul 29, 2007
    #14
    how do u get onto the windows registry?

    hey guys.
    Just wondering how do you go to the windows registry? how do you get there?

    thanks
     
  15. flopticalcube macrumors G4

    flopticalcube

    Joined:
    Sep 7, 2006
    Location:
    In the velcro closure of America's Hat
    #15
    RegEdit
     
  16. odinsride macrumors 65816

    odinsride

    Joined:
    Apr 11, 2007
    #16
    My windows time jumps forward as well after doing the registry hack. Is there a fix for this?
     
  17. Bill Gates macrumors 68020

    Bill Gates

    Joined:
    Jun 21, 2006
    Location:
    127.0.0.1
    #17
    That's due to the Boot Camp time synching application. I haven't looked into it, but if you disable it, the time should be spot on. I don't know why Apple didn't use the registry key, to use UTC, and instead chose to use their shoddy time program.
     
  18. coocooforcocoap macrumors regular

    coocooforcocoap

    Joined:
    Sep 22, 2007
    Location:
    kathmandu, nepal
    #18
    i had the same problem and was baffled but after upgrading my parallels install, it went away!
     
  19. rainforest1155 macrumors newbie

    Joined:
    Oct 9, 2007
    #19
    What I did to fix this problem was to disable the automatic daylight adjustment in Windows. You can do this in the timezone settings when you double click on the clock in the taskbar.

    Sebastian
     
  20. dangkevin macrumors newbie

    Joined:
    Nov 9, 2007
    #20
    Hi,

    How do you disable the time synching application in boot camp?

    Kevin Dang.
     
  21. Bill Gates macrumors 68020

    Bill Gates

    Joined:
    Jun 21, 2006
    Location:
    127.0.0.1
    #21
    Try removing it from your startup list using msconfig. However, like I said, I haven't looked into it.
     
  22. odinsride macrumors 65816

    odinsride

    Joined:
    Apr 11, 2007
    #22
    any resolution yet for the time jumping forward problem? it's still doing it for me...
     
  23. m1ss1ontomars macrumors 6502

    Joined:
    Oct 1, 2006
    #23
    That's right; this is a Boot Camp known issue. It's because of the different ways Windows and Mac OS X store and read the system time with respect to your time zone.
     
  24. jeamland macrumors newbie

    Joined:
    Nov 15, 2006
    #24
    SOLUTION:

    1 - set the realtimeisuniversal setting as described above.
    2 - go into control panel -> administrative tools -> services (or "manage computer" and go to services) and select "apple time service". set this to be DISABLED and it won't change your clock again.

    works fine :)
     
  25. BrownPlopz macrumors regular

    Joined:
    Feb 25, 2008
    Location:
    Behind you, I'm your shadow...
    #25
    So, just one more time, doing the following procedure should stop my Mac partition's clock from moving backwards 4 hours every time I reboot back into OS X, right?
     

Share This Page