Bootcamp crashed and lost Harddrive space?

Discussion in 'Windows, Linux & Others on the Mac' started by chriscordell, Dec 15, 2010.

  1. chriscordell, Dec 15, 2010
    Last edited: Dec 19, 2010

    chriscordell macrumors newbie

    Dec 15, 2010
    Hi there I used boot camp to put in a partition on my harddrive for XP. But it crashed like 3/4 of the way thorough the partitioning section.

    This made my available space about 30 gb (the size I had set the partition to) less than it was before. The partition doesn't show in finder, nor does it show in disk utility.

    I've tried to repair the disc using 'disk utility' but it says it can't repair the disc as its the 'startup disc'.

    If I view the permissions I get the following:

    Verifying volume “Macintosh HD”
    Performing live verification.
    Checking Journaled HFS Plus volume.
    Checking extents overflow file.
    Checking catalog file.
    Checking multi-linked files.
    Checking catalog hierarchy.
    Checking extended attributes file.
    Checking volume bitmap.
    Checking volume information.
    Invalid volume free block count
    (It should be 10831761 instead of 2776005)
    The volume Macintosh HD was found corrupt and needs to be repaired.
    Error: This disk needs to be repaired. Start up your computer with another disk (such as your Mac OS X installation disc), and then use Disk Utility to repair this disk.

    Has anyone got any ideas without having to format the harddrive and start again? I've not got idefrag or diskwarrior either so I cant use either of those :(

    Thanks in advance!!
    Ok so I cant read and I'm a bit stupid at times!

    If any one lese had this problem and was woried about 'reinstalling' OSX its no biggies.

    Just put in the boot disks (My mac came with leopard, although it still runs snow leopard the leopard disk still worked) and it will as to install. This is fine!

    Tell it to resart the Mac and then when it re-boots the at the top there will be options for utilities. click disk utility and then as it to repair the disk (note it works here)

    This fixes it :)

Share This Page