Bootcamp:"disk cannot be partitioned because some files cannot be moved"

Discussion in 'Windows, Linux & Others on the Mac' started by buddy39914, Apr 19, 2011.

  1. buddy39914, Apr 19, 2011
    Last edited: Apr 19, 2011

    buddy39914 macrumors newbie

    Joined:
    Mar 18, 2008
    #1
    So I am trying to install Windows 7 on my mac through Bootcamp and when trying to partition the disk I got: "The disk cannot be partitioned because some files cannot be moved" message.

    (I have a Time Machine backup of my mac, just did it now)

    And then I read that you have to format your mac, which I do NOT want to do. But heard that there was another option by using iDefrag.

    Can someone explain to me step by step (because I have no idea) what to do and what is the easiest or fastest method. What can I do to be able to partition my disk to install W7?
     
  2. johnnj macrumors 6502a

    Joined:
    Dec 11, 2008
    Location:
    Not here
    #2
    I used to encounter this back in the stone ages of me running a single drive config.

    I found that the easiest fix was to:

    1. Make a TM backup
    2. Boot off the OSX installer disk
    3. Use Disk Utility to make the partitions as you like (1 OSX, 1 FAT32)
    4. Use the restore utility to restore from your just-made TM backup
    5. When it's done boot into OSX just to check it and make yourself feel better that you can use your computer again if you want to.
    6. load the Win7 install disk
    7. Option-boot into the installer, use the setup disk selector to convert your FAT32 partition to NTFS (it won't install otherwise).
    8. Install Windows like anyone else would

    I guess you could use a defrag util, but that has the potential of taking longer than doing a backup and restore, depending on the level of fragmentation and how big your restore is.

    The Time Machine bare metal restore was one of the things that lured me away from being a stalwart Windows guy. I screw around with my machines a lot and just with this new one I've probably done at least a dozen wipe and restore jobs to it.

    Hope this helps.

    John
     
  3. buddy39914 thread starter macrumors newbie

    Joined:
    Mar 18, 2008
    #3
    Oh yeah.... I don't have the disc that came with MY mac. But I do have a Mac OS X Install DVD that came with an iMac i just bought. will it work?
     
  4. johnnj macrumors 6502a

    Joined:
    Dec 11, 2008
    Location:
    Not here
    #4
    Oh.. probably not. I know that my wife's 13" uMB wouldn't boot off of the one that came with my '09 15". I think it'll stop you when it boots, so you can try and see if it at least boots off of the DVD. Not sure if they package different Bootcamp drivers for different machines or if there's a single package that just installs ones that are relevant to the machine.

    You might end up having to get a generic disk from the store. You're better off having one around, anyway.
     
  5. buddy39914 thread starter macrumors newbie

    Joined:
    Mar 18, 2008
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8F190 Safari/6533.18.5)

    Ok, I THINK i was able to boot off of the disk.
    The first thing that came up (now) was a screen that says

    Mac OS X cant be inatalled on this computer.
    If you wqnt to restore your system from a Time Machine backup, click restore from backup.

    Then i get the options: restore from backup and restart.

    What should i do?

    I am on step 2 after booting, before step 3
     
  6. johnnj macrumors 6502a

    Joined:
    Dec 11, 2008
    Location:
    Not here
    #6
    Well, I guess if it'll let you run Disk Utility and the restore tool, then it'll work.

    I don't know.. it'd make me nervous not to have the proper disk, though.
     
  7. buddy39914 thread starter macrumors newbie

    Joined:
    Mar 18, 2008
    #7
    Yep it did work.

    Had to format my HD, then use my Time Machine backup.
    I went to BootCamp Assistant and tried to partition again (successfully).
    Then went to install Windows 7 on my Mac, and was able to install the drivers from the OS X Install DVD that came with my other Mac I had bought.

    It all seems to be working well. Thank you.
     
  8. johnnj macrumors 6502a

    Joined:
    Dec 11, 2008
    Location:
    Not here
  9. GiSqOd macrumors newbie

    Joined:
    Feb 22, 2013
    #9
    Alternative Solution

    I was able to solve this issue without cloning/restoring my entire system and wanted to share the alternative solution for anyone else who had this problem.

    My setup: MacBook Air Mid 2012, 128 GB Hard Drive. Time Machine backup to Western Digital NAS.

    I attempted to create a 32 GB Boot Camp partition with about 50 GB of free space on the MBA hard drive and got the same error: "Disk cannot be partitioned because some files cannot be moved." The OP's idea of defragging the hard drive seemed reasonable to me, so I did 3 things:

    1. Made sure I had a current Time Machine backup. (Obviously the first step)

    2. I then freed up as much space as I could on my hard drive. This included copying my iPhoto Library file (the largest file on my machine at ~15 GB) to the external NAS hard drive and deleting the iPhoto Library from my MBA. (I put it back once I was all done with the Boot Camp Assistant)

    3. Finally, I ran Disk Utility on the drive to repair broken sectors and permissions. I restarted the machine and held down the Option key to select the recovery drive. My MBA didn't come with a system disk (no optical drive), just a built-in recovery partition. If you have a system disk, boot from that. I ran Disk Utility and found a few damaged sectors on the MBA hard drive. After repairing them and verifying the permissions, I restarted and booted up using my hard drive.


    After doing this, the Boot Camp Assistant worked just fine. I think the combination of freeing up a little more space and fixing the bad sectors (sorta like a defrag process would) gave the drive a large enough block of space to work with. Plus, no need to stress myself out with wiping out the drive and restoring - no matter how much I trust Time Machine, that's always a little scary.

    Hope this helps someone. :)
     
  10. murphychris macrumors 6502a

    Joined:
    Mar 19, 2012
    #10
    Disk Utility doesn't fix bad sectors. The drive firmware does this usually before the sector truly goes bad and in the meantime masks any sector problems from even the SATA controller on up (kernel, fsck, Disk Utility). So I think what happened here is free up space removed the files most responsible for fragmentation, and possibly Disk Utility cleaned up the file system in a way that further allowed for a successful resize.
     

Share This Page