Bootcamp drivers not installing..

Discussion in 'Windows, Linux & Others on the Mac' started by comda, Mar 4, 2015.

  1. comda, Mar 4, 2015
    Last edited: Mar 4, 2015

    comda macrumors 6502a

    comda

    Joined:
    Mar 15, 2011
    #1
    Greetings!

    Alright. I know i posted this in the other section but this post is a LOT more clear. So let me explain because i need help. I have a Macbook 3,1 from 2007 Running Snowleopard and now windows 7 home premium 64bit.

    I use a Microsoft bluetooth mouse 5000 which I love but i cant get it working on this system because the bluetooth driver refuses to install. Windows instead installs a "Generic Bluetooth Driver" which connects my mouse but gives me an error and wants me to trouble shoot. When i try to manually install the Bluetooth driver, the install tells me its not needed. Yet that is incorrect. So i want to know how to trick this windows 7 install to get the flipping correct driver in.

    I also thought maybe i could find the driver from the actual manufacturer but i have no idea what it is. Ive tried looking in the device manager to get the VEN ID to check PCIDATABASE.COM but it does not display the correct information. Ive tried speccy, and everest home but still cant figure it out. I need this driver badly.

    Hope this clears things up from my really bad first post. Thanks for any help.
    EDIT: just added photos.. haha forgot..
     

    Attached Files:

  2. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #2
    Which version of Bootcamp are you trying and where did you get it?
    Did you run the full Bootcamp setup or did you drill down into the package to install only the Bluetooth driver?
    Have you tried going into the Device Manager, removing the Mouse, removing the Bluetooth receiver, and then immediately installing the full Bootcamp setup?
     
  3. comda thread starter macrumors 6502a

    comda

    Joined:
    Mar 15, 2011
    #3
    Gjwilly, thanks for the reply.

    I used the last version of bootcamp that can run on this system, Bootcamp 4.0.40333 and i installed it from the main package. I tried un installing the bluetooth adapter but i guess i can run the setup again and try what you suggest. As for the mouse it doesnt stay on the system it disappears.
     
  4. comda thread starter macrumors 6502a

    comda

    Joined:
    Mar 15, 2011
    #4
    I tried uninstalling the device from device manager, then running the bootcamp again.. i got a message saying the "generic driver failed to install" and still the same thing.
     

    Attached Files:

Share This Page