Bootcamp Drivers not recognized

Discussion in 'Windows, Linux & Others on the Mac' started by sarsnik, Sep 11, 2009.

  1. sarsnik macrumors newbie

    Joined:
    Sep 11, 2009
    #1
    Sorry about the long post, I have a tendency to rant sometimes so please bear with me; I could really use some help :p

    I have a pretty new macbook pro that was purchased in the middle of August. Everything is great although, much to my dismay, Empire total war is not mac compatible.

    No worries though, being pretty confident with computers, I can just install windows in a small partition to use exclusively for gaming, or so I thought. :(

    I installed a slipstreamed version of windows xp professional SP3 without any troubles, but I cannot for the life of me, figure out how to get the bootcamp drivers installed.

    Now before I continue, I am using drivers which I downloaded from a torrent (v2.0) and the version 2.1 drivers from the Apple site, as I am a college student and I left the OSX leopard disks back at my house. I know torrents are not particularly reliable but after a close inspection of the files, they seem to all be there, and seemed legitimate. I also have read that the OSX disks have the drivers for ALL Mac hardware.

    Also, the I know that you are supposed to install 2.1 before you install sp3, but I have read that this is ONLY because you cannot reinsert the windows disk to verify the upgrade. In my situation, I am not installing from the leopard disks, so my disk drive is free to make this validation of my windows OS.

    So heres my issue:

    When I run the setup executable, It installs without and apparent errors, however when I check the status of the hardware in the windows device manager, all of the apple hardware (ex. iSight, VGA card, Sound card) do not have drivers assigned to them (they have the yellow question-mark icon). However, when I open up the 'add remove programs' utility, It displays all of the drivers that were installed from the bootcamp setup.

    Here is what I have tried so far, in order:
    -Installed only bootcamp 2.0 drivers (didn't recognize them)
    -Tried to install only 2.1 drivers (wouldn't install unless 2.0 was installed)
    -Installed 2.0 then 2.1 (Didn't recognize either of them)
    -Reinstalled windows (I thought the OS may have been corrupted)
    -Tried the first three steps again on the fresh OS install
    -Became sad

    Any and all help would be appreciated. Ironically, the only problem that I have had so far on my mac is installing windows, so hopefully someone who has had the same problem might be able to help!

    Thanks
     
  2. aidricksdad macrumors regular

    aidricksdad

    Joined:
    Dec 29, 2008
    Location:
    Round Rock
    #2
    i would drive me to kill to play that game on a laptop......i used to play rome total war on a laptop and that was hard enough
    plus empire is very graphic intensive
    soory i didnt help with your windows problem
     

Share This Page