Bootcamp drivers will not install

Discussion in 'Windows, Linux & Others on the Mac' started by Mac4Brains, Jun 28, 2012.

  1. Mac4Brains macrumors member

    Mac4Brains

    Joined:
    Oct 18, 2005
    #1
    The bootcamp program on the Mac side downloaded the drivers and placed them on my thumb drive. Now that Windows7 is installed, I go to the drivers and run setup and I get a message saying "Boot Camp x64 is unsupported on this computer model" on my iMac. anyone have any idea how to get the drivers to install?
     
  2. XFactorer macrumors regular

    Joined:
    Feb 2, 2007
    Location:
    Eugene
    #2
    Sounds like your iMac isn't x64 compatible. Perhaps go with Windows 7 x86?
     
  3. Mac4Brains thread starter macrumors member

    Mac4Brains

    Joined:
    Oct 18, 2005
    #3
    I found the fix on the web

    After looking around on the web for answers I found this and I got the drivers to install. it is strange that Apple appears to not ever acknowledge the issue at all and it appears that several people have hit this issue.

    Click start (or the windows icon in the lower left of your screen)

    Then go to “all programs”

    Then go to “accessories”

    Then right click on “command prompt” and choose “run as administrator”

    The commands you want to enter are:

    D: then press enter

    To get the next parts to work it is best if you have "show file extensions" and "show hidden files" turned on so you can find the file to figure out the path.

    Now the file you are looking for is called "BootCamp64.msi". There is a file at the root level of the folder that is next to the “setup.exe” with the same name but it is a “.xml”, that is not the one you need. In my case the file was in another folder.

    The path I used for a thumbdrive install was (as I typed it in to CMD)
    E: WindowsSupport\Drivers\Apple then press enter.

    If you working of a CD/DVD copy you might need to figure out the path but the file ends with “.msi” and it will be in a folder called “Apple” that is in a folder called “Drivers”

    Type in bootcamp64.msi then press enter

    This should open a installer and install the drivers to get Winblows going.

    ----------

    I have a iMac24 Intel 2.66 and I installed the 64bit version of Winblows7. it should have worked. I discovered that a lot of people have hit this issue.

    This is a reinstall after I did something stupid. it worked fine in the last install.
     
  4. rollandburn macrumors newbie

    Joined:
    Nov 20, 2012
    #4
    Perfect... I had missing drivers for 'Other Devices' after installing Win7 and this posting helped me out. I followed the instructions exactly as above (mmm... different usb key drive letter, I had F:) and after a restart, voila. Thank you very much sir.
     
  5. ianhowell6427 macrumors newbie

    Joined:
    Aug 28, 2013
    #5
    The above solution almost works flawlessly

    I would add (since I'm reading this trying to shove Windows 7 64 bit into a non-apple approved Mid 2009 Macbook), that first one needs to navigate to the [thumbdrive]:WindowsSupport\Drivers\Apple folder through the regular windows file viewing windows and double click the "AppleTrackpadInstaller.exe" file. Then, now that you can right click, goto the start menu, and right click on command prompt to "run as administrator" following the rest of the instructions.

    It seems to be working... Final restart...

    Success!

    ~Ian
     

Share This Page