Bootcamp Erased OS X?

Discussion in 'Windows, Linux & Others on the Mac' started by jay6457, Jun 26, 2008.

  1. jay6457 macrumors newbie

    Joined:
    Jun 26, 2008
    #1
    Hey everyone, I have a MBP, and I tried installing XP via bootcamp. While installing, the setup told me that certain files for XP were missing and I chose to disregard it until it came up a few more times. After I canceled in installation and reset, I tried to return to OS X but couldn't. I popped in the OS X install CD and when it asked me to choose where to install, there weren't any volumes to choose from. Did I erase OS X? If so, how can I fix this problem? Thank you.
     
  2. Zaeyde macrumors member

    Joined:
    Jun 26, 2008
    #2
    I had the exact same problem. Apple Care told me the laptop was shot.
    I was able to fix it, though I erased the disk.
    Try using Disk Utility and putzing around in there until it recognizes it again.
     
  3. Stridder44 macrumors 68040

    Stridder44

    Joined:
    Mar 24, 2003
    Location:
    California
    #3
    Maybe you installed on the wrong partition?
     
  4. jay6457 thread starter macrumors newbie

    Joined:
    Jun 26, 2008
    #4
    Thanks Zaeyde. I didnt know you could run disk utility without logging into OS X. I was able to use it from the install disc and i repaired the Mac partition and erased/unpartitioned the XP one. Cheers
     
  5. Zaeyde macrumors member

    Joined:
    Jun 26, 2008
    #5
    That's exactly what I did, only first I cried, drove 45 minutes to a mac store, ordered a new one, cried more, came home, and then figured it out. xD
     
  6. misteron macrumors newbie

    Joined:
    Jun 23, 2008
    #6
    I think I have the same problem.
    Only diff seems to be that the previous poster refers to repairing the Mac partition, whereas for me, I don't seem to have a Mac partition anymore.

    in the left pane of Disk Utility I have:
    186.3 GB Hitachi
    and underneath that with an indent from the left is:
    disk0

    Underneath that (where the info appears for whichever of the above is selected) it gives the following info for the first entry:

    Disk Description: Hitachi HTS7..[bla]...00 Media
    Connection Bus: Serial ATA 2
    Connection type: Internal
    Total capacity: 186.3GB
    Write Status: read Only
    SMART Status: verified
    Partition Map Scheme: Unformatted


    And for disk0 it gives:

    MountPoint: /volumes/Untitled
    Format: Windows NT File System (NTFS)
    Owners Enabled: No
    Number of Folders: 0
    Capacity 186.3GB..
    Available: 127.5 GB..
    Used: 529.4MB..
    Number of files: 3232


    ...all of the options on all of the following tabs;
    First Aid, Erase, Partition and Restore
    are greyed out for both the drive ("186.3 GB Hitachi") and the partition ("disk0").

    Selecting disk0 in the left pane enables the "Unmount" option in the top toolbar.
    As disk0 is listes as a NTFS partition the same size as the available portion of the drive, I wonder if it's necessary to Unmount it.
    Or, maybe erase disk0 with the Windows Install disk.
    Any thoughts?

    One other option is that the Leopard install Disk gives an option to restore from TM.
    The only vol it gives me the option to restore to is just referred to as Restore Destination Volume but is 128GB which makes me think it is disk0 coz disk 0 is marked as TotalCapacity: 186.3GB and Available: 127.5GB in Disk Utility.
    So it seems that trying to restore from TM at this point, before installing Leopard, would be messy and possibly ineffective.

    Can anyone advise me please?

    Thanks,
    m
     
  7. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #7
    Looks like you erased your hard drive. Best bet is to make a new partition and then just reinstall Mac OS X.
     
  8. misteron macrumors newbie

    Joined:
    Jun 23, 2008
    #8
    Thanks for the reply.
    Plese see above,
    Thanks,
    m
     
  9. lectern macrumors newbie

    Joined:
    Aug 21, 2008
    #9
    I have exactly the same problem, disk utility greys out the hdd so you cant erase. Im taking mine to apple store on saturday. Have you managed to fix yours yet.

     
  10. lectern macrumors newbie

    Joined:
    Aug 21, 2008
    #10
    I'm not going to mess around here. This could get ugly, fast!

    It is very likely that your data is non-recoverable at this stage, so you will be reinstalling Leopard to get back to a working state.

    Before you do that, however, you need to use the Windows disc to remove the partition that was created. To do this, pop the Windows disc into the DVD drive, Option boot to the disc, and press a key to start. When Windows Setup starts, press R to enter recovery mode.

    In recovery mode, you're working with an MS-DOS-like command line. Here, type:

    diskpart <Return>

    Select any NTFS partitions you see, and press D, <Return>, L.
    This might help got it from apple forums

    Now, press ESC to exit, and type:

    exit <Return>

    Option boot again, and eject the Windows disc with your <Eject> key. If this fails, reboot while holding the mouse button.

    Now, restore your Mac.

    When you try Boot Camp again, make absolutely sure that your Windows disc has SP2 or later. Using earlier versions may have been the root cause of your trouble, as these versions do not support advanced hardware or large hard disk, as Macs have. You can apply SP2 via "slipstreaming" your own disc.

     

Share This Page