Bootcamp eSATA BOOT "Crashing with B.C. driver's"

Discussion in 'Windows, Linux & Others on the Mac' started by hdcam4010, Sep 27, 2010.

Thread Status:
Not open for further replies.
  1. hdcam4010 macrumors newbie

    hdcam4010

    Joined:
    Sep 20, 2010
    #1
    Need Help, Crash after reboot with BootCamp drivers 64 Bit. Can anybody please help me and explain why this happening.

    Mac Pro G5 model 4.1 early 2009 with 16GB ram OSX 10.6.4, WIndows7 64 BIT

    Single eSATA drive partition /dev/sda1 Windows 7 /dev/sda2 ubuntu using MAster BOOT Record in PCI Slot 3

    Slot 1 Radion ATI 4870 1024 x 2 Graphic's card & Slot 2 i'm using 2 500GB slice RAID 0 eSATA with HighPoint Rock RAID eSATA for MAC card with OSX 10.6.4 boot as 1st partition.

    NewerTech MAXPower eSATA 6G PCIe 2.0 Controller Card "only bootable BIO Windows AHCI" http://www.newertech.com/products/pcieesata.php

    I use "johnsock's script in "Terminal" found here http://osx86.co/f74/how-to-boot-mac-pro-in-ahci-mode-t3159/

    Works with reFIt, im able to boot Windows 7 64 BIT & UBUNTU 10.10 AMD 64 beta & 10.04. I plan on using 10.10, GM will be release on 10/10/2010. i figure i would go ahead install beta. When crash kept happening i went back to 10.04 to see if that was problem. last few times i haven't had UBUNTU install.

    Ever thing runs great up until BootCamp 3.1 drivers are install from OSX DVD or manually with administrator permission.

    Error log has this once i boot back to Win 7 in safe mood "i've look it up and most post say's hardware issue. I've run several utilities in OSX all reports come back with out any errors. The crash only happens after reboot in Windows after i install BootCamp Drivers. I also ran disk repair in OSX with paragon driver to see if it would fix the issue, no luck.

    ------------------------------------------

    Problem signature:
    Problem Event Name: BlueScreen
    OS Version: 6.1.7600.2.0.0.256.48
    Locale ID: 1033

    Additional information about the problem:
    BCCode: 34
    BCP1: 0000000000000107
    BCP2: FFFFFFFFC0000420
    BCP3: 0000000000000000
    BCP4: 0000000000000000
    OS Version: 6_1_7600
    Service Pack: 0_0
    Product: 256_1

    Files that help describe the problem:
    C:\Windows\Minidump\092710-38469-01.dmp
    C:\Users\wbs\AppData\Local\Temp\WER-56253-0.sysdata.xml

    Read our privacy statement online:
    http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

    If the online privacy statement is not available, please read our privacy statement offline:
    C:\Windows\system32\en-US\erofflps.txt

    --------------------------------------------------
     

    Attached Files:

  2. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #2
  3. hdcam4010 thread starter macrumors newbie

    hdcam4010

    Joined:
    Sep 20, 2010
    #3
    i've tried that also but not with 7-zip, i use winRAR 64. I stated this project over week ago with out RockRaid. I purchase rockraid on Friday, hoping to solve problem. I was mis-lead i think, im not going to beable to use it for triple boot with all 3 OS's. I plan on researching it later today to see if thats possibilty. So far im not able to get windows EFI BIO to install with rockraid. I was having same problem with NewerTech all week long. i only bought Rockraid because it was bootable OSX was hoping it would solve my problem. I need to get Windows install on eSATA. All 4 bays plus Spare optical bay is being used in RAID 0.
     
  4. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #4
    So which specific driver from the Boot Camp package actually causes the issue?

    It's really hard to try and help you if you a) give us mis-leading information (There is no Mac Pro "G5") b) incomplete information (that you tried individual drivers and c) too much information so that we have to dig through to figure out what is relevant.

    Refer to the thread: "How to maximise your MacRumors troubleshooting experience"

    B
     
  5. hdcam4010 thread starter macrumors newbie

    hdcam4010

    Joined:
    Sep 20, 2010
    #5
    oh, sorry about the "G5" i didn't realize Apple change it with Intel processor.

    It's MacPro 4.1 8 core 2.26GHz x2 (early 2009)

    I'm not sure about the driver, im only install 64 Bit from the folder that says (x64) it contains bluetooth, keyboard, & etc .... Also the intel driver.
     
  6. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #6
    That's (a big part of) the problem.

    You need to isolate the problem.

    e.g. Remove all hardware that is not essential for use in Windows. Keep only the eSATA card you need for the Windows drive. Make that work. Then reintroduce everything else. If you can't make that work, find another eSATA card that will.

    OR

    Do a clean install of Windows, and don't install any drivers that Windows didn't provide. Reboot. Install one driver (could be SATA/chipset related, or the opposite e.g. Keyboard). Reboot. Test. Repeat with the next driver. etc...

    STEP, BY PAINFUL STEP. Until you find the specific place it breaks.

    You can't troubleshoot a system this complex without taking it back to something simpler.

    B
     
  7. hdcam4010 thread starter macrumors newbie

    hdcam4010

    Joined:
    Sep 20, 2010
    #7
    Ok, ill try that tonight and post results. Do you know which driver that allows you to see the OSX drive? Thanks for help

    I forgot to post this, in "johnsock's script in "Terminal" it says to

    - Run Regedit
    - Navigate to "HKLM\System\CurrentControlSet\Services\msahci "
    - edit the "Start" key and change the value from what it is to "0"
    - this will tell Vista to check for AHCI on next boot and install the AHCI driver if it is in AHCI mode
    - this installs the generic AHCI Microsoft driver and it is really a poor driver for your hardware and you will need the Intel ones to get full performance.

    It says to use this Driver ""Intel® 631xESB/6321ESB Ultra ATA Storage Controller - 2680"

    Which Im not able to install.
     
  8. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #8
    Try to get performance after you get it to work. Performance is meaningless if it will BSOD.

    Get it to work with the stock Microsoft AHCI drivers and then think about installing something faster.

    B
     
  9. hdcam4010 thread starter macrumors newbie

    hdcam4010

    Joined:
    Sep 20, 2010
    #9
    External eSATA Boot update

    So far so good with 64BIT driver's from x64 folder. i only install ones i thought i would need. I use 7-zip this time, with backup Win7 OS Paralle 6.0 virtual image. Posting screen shots, any advice to help would be appreciated.

    Here are issue's i like to try to solve.
    # unable to access any drives except the external eSATA drive which Windows 7 Pro is install. I install Paralle 6 in OSX & tools hoping it would allow me to access my OSX drives, using share feature. It doesn't work.

    # after i install or update, the reboot hangs and i have to shut CPU down. Only way to boot up, i have to turn off Windows Drive. BOot up to external eSATA RAID 0 OSX drive with rEFIT. Then turn on Windows Drive reboot then able to boot Win7 with rEFIT. Key note, i have Tinker Tools 2 install with mount external drive before log-in turn on.

    # Eject button on Mac Keyboard is not working. Im not able to eject internal CD/DVD super drive unless i right click on inserted disk or from C drive. This isn't the end of the world.
     

    Attached Files:

  10. flyingphish macrumors newbie

    Joined:
    Aug 22, 2010
    #10
    try this it worked for me.

    do not install bootcamp.

    only thing missing after the windows7 install was sound in which i only installed that driver from the bootcamp dirctory on the osx install disk. sure the keyboard shortcuts dont work and i cant see the other drives on the computer but i am only using windows7 for playing Call of Duty and some aviation software from jeppesen/boeing, they dont do Mac. I also downloaded the latest video drivers (ATI catalyst for 5800 cards)

    bootcamp seems overrated and causes a lot of problems....thats all i read, bootcamp this bootcamp that. i chose to skip bootcamp.
     
  11. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #11
    Minor point, but you are still using Boot Camp.

    You may choose to skip the assistant or not to install the drivers, but without the firmware component of "Boot Camp" you wouldn't be able to boot Windows in the first place. And, yes it now comes pre-installed, but essential none the less.

    (The main problem with the Boot Camp driver package is that Apple chooses to install all the drivers for all Macs, which means a lot of stuff you don't need gets installed).

    B
     
  12. hdcam4010 thread starter macrumors newbie

    hdcam4010

    Joined:
    Sep 20, 2010
    #12
    Update

    I have Windows 7 64BIT updated with current drivers runs great except not being able to use Bootcamp Drivers from OSX install DVD. I have 7.4 overall rating out of 7.9.

    Has anyobne been able to install BootCamp Drivers 64 BIT for windows 7 on Master Boot Record formatted drive? if so how did you do it?
     
  13. hdcam4010 thread starter macrumors newbie

    hdcam4010

    Joined:
    Sep 20, 2010
    #13
    Update

    I just got windows 7 64 bit to boot using NewerTech MAXPower eSATA 6G PCIe 2.0 Controller Card on GUID DRIVE.

    It's only suppose to work this way:

    "Supports booting in Windows (Vista & Window 7) with AHCI mode enabled in the BIOS. Does NOT support booting on any Macintosh platform."

    My previous post when booting I use Master Boot Record.

    Making system image & restore disk now.Then I'm going to try to get BootCamp Drivers to install on GUID. I took screen shoots and pictures with my phone. I'll start new thread with detail directions if this works with drivers.
     
  14. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #14
    Glad to hear you're making progress!

    B
     
  15. hdcam4010 thread starter macrumors newbie

    hdcam4010

    Joined:
    Sep 20, 2010
    #15
  16. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
Thread Status:
Not open for further replies.

Share This Page