Bootcamp firewire drivers under XP?

Discussion in 'Windows, Linux & Others on the Mac' started by wallaby, Dec 27, 2007.

  1. wallaby macrumors 6502

    wallaby

    Joined:
    Jun 5, 2007
    Location:
    Iowa
    #1
    I have a question…I've read that Windows XP Service Pack 2 included support for both firewire 400 and 800 interfaces (up from just fw400 before), but the included update reduces the speeds on these to around 100mbps (well under their capabilities, and slower than USB!). That's with default XP drivers though, supposedly. My question is, does Bootcamp come with the drivers to make fw800 full speed? I want to run a couple high-stress games from my external drive to my MBP (Battlefield 2 and 2142), so I was wondering if anyone experienced problems with firewire speeds under XP.
     
  2. wallaby thread starter macrumors 6502

    wallaby

    Joined:
    Jun 5, 2007
    Location:
    Iowa
    #3
    Yes, I know this already, having referred to this in my post. My question is whether Apple includes its own firewire drivers in Bootcamp that are full speed rather than the XP SP2 default. Or if your personal experience with firewire in Bootcamp has been satisfactory.
     
  3. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #4
    I didn't notice any sort of performance penalty using FireWire in Boot Camp.

    I wasn't running a game off of an external though.
     
  4. mike steiner macrumors newbie

    Joined:
    Jan 26, 2008
    #5
    Looking for more help!

    I run protools from a firewire wire drive and am having problems with information transfer wile running the program. I am running windows xp with bootcamp from Lepord . I have installed multiple hot fixes from microsoft for firewire ports and dual core processors.

    I was wondering if anyone else has this problem. I get an error in prtools that tells me to increase the Hardware Buffer size.

    Just wondering if anyone else has had this problem and or a solution.
     
  5. MarkWestbroek macrumors newbie

    MarkWestbroek

    Joined:
    Mar 25, 2008
    Location:
    Netherlands
    #6
    Same problem, but there may be hope

    Yes, I can confirm having the same problems on my MBP with bootcamp and XP. Haven't been able to set buffer size to less than 256 in my Motu 828MK3 firewire audio interface, leading to latency of about a quarter of a second. Lower values lead to hampering, 'broken' sound or just high peeep sounds and a few clicks. The interface seemed to work well under OSX.

    But found this thread:
    http://forums.macrumors.com/showthread.php?t=247298&page=7

    Saying something about turning the WiFi system off. Haven't been able to try (at work now), but will tonight.

    Also, there is:
    http://discussions.apple.com/thread.jspa?messageID=5728497
    Talking about shared IRQs. Sounds scary, I must say.

    Anyone having a solution or the same problem most welcome!

    Also: does anyone know a way of testing Firewire speed?

    Cheers,

    Mark
     
  6. yair macrumors newbie

    Joined:
    Apr 15, 2008
    #7
    MarkWestbroek- there is an xp program to check latency of external processes. its not firewire specific afaik, but wil show you some information.

    i still experience limited 1934 bandwidth,
    i have a high speed fw camera (pixelink) and the bandwidth problems make it unusable at high framerates.

    i followed all the hot patches and disabling the wireless connections. still no go. on every other xp machine it works.


    see (among many)-

    Gearslutz.com - View Single Post - Windows on a Macbook Pro?
    http://www.gearslutz.com/board/1961838-post3.html

    Apple - Support - Discussions - Can I delete Realtek Drivers & use ...
    http://discussions.apple.com/thread.jspa?messageID=6988825&#6988825

    RME Tech Info - FireWire 800 under Windows XP SP2
    http://www.rme-audio.com/english/techinfo/fw800sp2.htm
     
  7. markhamilton99 macrumors newbie

    Joined:
    May 13, 2008
    #8
    just literarly replace 1394bus.sys and ohci1394.sys with the same files from SP1 and you will get 800Mbit working
     
  8. briangelfand macrumors newbie

    Joined:
    Oct 24, 2008
    #9
    problems with external hard drive

    Yeah I have issues with firewire external hard drive- running Sonar 8 on a Mac Book with Bootcamp. But my MAudio Firewire 410 seems to work just fine both with the internal drive and also an external USB 2.0 drive.
     
  9. samo1215 macrumors member

    Joined:
    Feb 26, 2008
    #10
    Does anybody know if this was corrected with service pack 3?
     
  10. CaptainCornwall macrumors newbie

    Joined:
    Mar 2, 2010
    #11
    RE: fire wire 400 prob wioth bootcamp

    with regards to the problem with fire wire on boottcamp, i know it can be fixed, as focusrite have a running fully working focusrite saffire LE on test, they have reliased all the instructions, i have follwed to the letter, but just cant get it weorking. dowen to manuaklly installing the driver in the device maniiger think ojn to something there but it does not work. cubase can see the safire, windows can its got soemthing to do with the wmd audio drivers not chanimng in the device maniger.

    any way rather than a lost of what to do can some one that has done this with success take over my pc via remote access or guide me step by step on messenger.

    i need help and fast HELP!!!
     

Share This Page