Bootcamp gone horribly wrong, Mac HD GONE

Discussion in 'Mac Basics and Help' started by Smurfed, May 1, 2008.

  1. Smurfed macrumors regular

    Joined:
    Apr 2, 2007
    #1
    So I was installing Windows XP via bootcamp, and chose Drive C to format it in , but that was weird cause it didnt show any of the usual other drives, so i selected it.

    After it was done installing it did the usual reboot, and after it rebooted all i get is a white screen.

    I rebooted it again holding down the option key to select which partition to boot from and... ALL PARTITIONS WERE GONE :eek:
    The Mac HD partition was gone, all I saw was the installation disc.

    So i thought i would just reformat the whole drive and reinstall Leopard, but while i was doing that, when it gets to the step "Select a destination to install Mac OS X" Nothing is listed :eek: and it cant continue the installation.

    So from the installer cd I went to Disk Utilities and confirmed that the Mac HD was gone and Windows partition from bootcamp mightve went over it and wiped it.And I cant even use that windows partition that was called "disk0" cause apparently is was formatted incorrectly.

    I cant create a new partition on disk utilities either cause the buttons are greyed out.

    What shall I do? I'm at an utter lost :(
     
  2. dops7107 macrumors 6502a

    dops7107

    Joined:
    Mar 19, 2005
    Location:
    Perth, Oztrailya
  3. Ice-Cube macrumors 6502a

    Ice-Cube

    Joined:
    Jul 27, 2006
    Location:
    Somewhere over the rainbow
    #3
    Instead of creating a new partition using disk utility, have u tried using the erase function?
     
  4. Smurfed thread starter macrumors regular

    Joined:
    Apr 2, 2007
    #4
    Yes, do you think I should install Leopard on an external?



    Yeah I tried that but no luck since the erase button is greyed out.
     
  5. runplaysleeprun macrumors 6502a

    runplaysleeprun

    Joined:
    Jul 27, 2004
    Location:
    Chicago, IL
    #5
    Seems to be one of the few, if not the only, option left to you at this point. I say go for it, nothing to lose at this point, right?
     
  6. Smurfed thread starter macrumors regular

    Joined:
    Apr 2, 2007
    #6
    If i install it on an external, can i format the original macbook pro hd while i'm on leopard using the external?

    also what if i formatted the partitions using pdisk on the terminal?
     
  7. Smurfed thread starter macrumors regular

    Joined:
    Apr 2, 2007
    #7
    Welps, I'm going to go call apple tech support tomorrow, then maybe head over the store and have the Genuises take a look at it.

    I've tried almost everything, resetting pram, single user mode (doesnt work), partitioning drive/ erase drive/ basically anything to format the original drive options are grayed out. Leopard doesnt recognize any HD to install the OS X in.

    So if you guys have anymore advice to help me out and save a trip to the apple store that would be great :D
     
  8. Smurfed thread starter macrumors regular

    Joined:
    Apr 2, 2007
    #8
    The Macintosh HD partition got replaced with the Windows NTFS Partition named 'disk0' and didnt even format properly.

    on Disk Utilities from the installation CD i pressed info button on it and it reads:

    Name: disk0
    Type: Volume

    Disk Identifier: disk 0
    Mount Point: /Volumes/Untitles
    File System: Windows NT File System (NTFS)
    Device Tree: /PCI0/SATA@1F,2/PRT0@0/PMP@0/@0:0
    Writable: No
    Capacity: 186.3 GB (200,049,647,616 Bytes)
    Free Space: 127.5 GB (136,904,531,968 Bytes)
    Used: 509.7 MB (534,417,408 Bytes)
    Number of File: 3,050
    Number of Folders: 0
    Owners Enabled: No
    Can Turn Owners Off: No
    Can Be Formatted: No
    Bootable: No
    Supports Journaling: No
    Journaled: No
    Disk Number: 0
    Partition Numer: 1


    Main Macbook Pro Harddrive:

    Name: FUJITSU MHY2200BH Media
    Type: Disk

    Partition Map Scheme: Unformatted
    Disk Identifier: Disk 0
    Media Type: FUJITSU MHY2200BH Media
    Media Type Generic
    Connection Bus: Serial ATA 2
    Device Tree: /PCI0/SATA@1F,2/PRT0@0/PMP@0/@0:0
    Locked: Yes
    Writable: No
    Ejectable: No
    Mac OS 9 Drivers Installed: No
    Location: Internal
    Total Capacity: 186.3 GB (200,049,647,616 Bytes)
    Free Space: 127.5 GB (136,904,531,968 Bytes)
    S.M.A.R.T. Status: Verified
    Disk Number: 0
    Partition Number: 0

    It seems it says Locked and unwritable, could that be why i couldn't partition it?
     
  9. Ice-Cube macrumors 6502a

    Ice-Cube

    Joined:
    Jul 27, 2006
    Location:
    Somewhere over the rainbow
    #9
    The result would be the same as using the Restore cd to format your HD. So I think its unnecessary to try that.

    I cannot imagine how a disk refuses to be formatted. Never came across that before.
     
  10. calguy macrumors newbie

    Joined:
    Jan 3, 2008
    Location:
    San Franciso Bay Area
    #10
    Since you have a MacBook Pro and you have an external disk, you can install the OS X there. But, is the external a 2.5" SATA drive? If so, you can swap out the the disk from the MBP and put in the new one and then install OS X on the new drive. Go to this video for instructions if you need to: http://media.macsales.com/medres.html If you don't have the same size disk and can wait for a new 200 GB disk, then I would recommend a 7200 RPM disk. This does read faster and transfer data faster and it does not drain my battery any faster that my original disk for my MacBook.

    Another option -- Your computer probably came with a disk called TechTool Deluxe. You can boot off of that and run the utility to see if can recognize or repair or reformat the drive. This takes a couple of minutes to boot from and will give some very basic tests. See if this will recognize the drive.

    Or -- Go back to Disk Utility on your install disk which you should have rebooted off of. On the left panel it should recognize Disk 0. If it doesn't and nothing there to select, it usually will ask you if you want to reformat the disk. If not, go to Erase to select a Volume format. You should use Mac OS Extended. It has other options below to erase free space. That takes extra time and with a 200GB drive. You will be waiting quite a while. So, without any special erasing which just gets rid of the links to the data only when it renames it and reformats it. If that works then install.

    Last option would be to go to Mac Genius Bar and seek help from there if you also didn't have Rescue II software to try.

    Good Luck! :)
     
  11. eclipse525 macrumors 6502a

    eclipse525

    Joined:
    Aug 5, 2003
    Location:
    USA, New York
    #11
    Unfortunately, I can't offer any help but I had a similar episode for the exception that I didn't choose the "C:" drive, knowing that I should be seeing a "Bootcamp" partition. I wound up quitting the installation. I've tried this process a few more times and all I kept getting when asked what partition to install Windows on is the following:

    "131070MB Disk 0 at ID 0 on atapi [MBR]
    C: Partition1 [unknown] 131072 MB (131071 MB free)"



    I personally can't understand what the issue is at this point. All software & firmware are updated. I'm using WindowsXP (SP2) and is legit. People seem to have the same problem but NO ONE seems to have a solution. I really wish it was something I was doing wrong.

    In any case, does anyone think that the installation would be successful if I did via Parallels? Any help would be GREATLY appreciated. Regards.


    ~e
     
  12. Smurfed thread starter macrumors regular

    Joined:
    Apr 2, 2007
    #12

    Does this mean i Have to buy a new internal 2.5" HD? even though this macbook pro is only a week old :T

    Unfortunately my machine didnt come with TechTool Deluxe, is it free to download?


    And on the last part I'm sorry I can't do anything to disk0 because all the options to verify, format, and etc are grayed out.

    On the HD info for disk 0 it says its locked and unwritable.
    Is there a way i can unlock it and make it writeable to format, maybe by using a terminal command?


    "131070MB Disk 0 at ID 0 on atapi [MBR]
    C: Partition1 [unknown] 131072 MB (131071 MB free)"


    Yeah that's exactly what i saw, and it was the only one to choose from as an NTFS format so i chose it, i wish i hadn't.
     
  13. calguy macrumors newbie

    Joined:
    Jan 3, 2008
    Location:
    San Franciso Bay Area
    #13
    No, you don't have to buy a new internal HD. I also suggested that if you also want one as a backup that you can clone your internal drive to. You get TT Deluxe with the AppleCare purchase which is the smaller version of TT Pro. You can download them from version tracker but I couldn't find a free trial period listed.
    You might also want to try iMount which will mount drives and partitions. It is free(beta version): http://www.versiontracker.com/php/q...n=search&str=iMount&srchArea=macosx&submit=Go

    Since your machine is only a week old, call AppleCare! It is a free service with techs standing by to help. Their only limit is that they follow Apple standards and will not experiment with non-Apple software with you.
    Did you run the Apple Software Update to make sure everything has the most recent versions?
    Hang in there!
     
  14. jackiecanev2 macrumors 65816

    jackiecanev2

    Joined:
    Jul 6, 2007
    #14
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko) Version/3.0 Mobile/4A102 Safari/419.3)

    another suggestion: if, for whatever reason, you cant get disk utility to format (which is weird but I suppose not impossible) I would try gparted. You can download and burn it. Its a livecd Linux-based formatting/partitioning software that supports os x formatting (hfs,+,journaled/extended etc). Then see if your leopard install will recognize the drive. Good luck.
     
  15. jp81, Jan 30, 2011
    Last edited by a moderator: Jan 30, 2011

    jp81 macrumors newbie

    Joined:
    Jan 30, 2011
    #15
    smurfed, please help

    can you tell me if you get this fixed. I got the exact problem. now i don't know what to do since I can't reinstall osx again
     

Share This Page