bootcamp gurus? spent 3 days and no go

Discussion in 'Windows, Linux & Others on the Mac' started by Rojoyinc, Feb 12, 2014.

  1. Rojoyinc macrumors newbie

    Joined:
    Sep 13, 2011
    #1
    I'm new to Macs - I've been a PC for 34 years (pretty computer GEEK - PC user). Long story short, I got a iMac and (no longer a PC) !!! never thought I'd say that.

    Anyway - I installed parallels and was quite impressed. I got into STEAM and got into gaming again. (after being a beta tester for activision about 8 years ago for several years.

    So I run several games via parallels - cool - but some don't like it. I hear bootcamp is the way to go. So - I ran the util. It downloaded the drivers, I put on a SD card in a USB reader and proceeded. It never finds my USB drive.

    GAVE UP. NEXT - I have external DVD and original WIN8 install disc. (as I own several PC's). Running bootcamp - it reboots, and boots from win8 DVD. Installs... looks good until it gets to partition. It says no partition is possible to install on. I read "format it" I do - and it changes from a partition to unallocated space. I spent 3 days trying all different things.

    Problems were I could not boot from DVD, but I could boot from EFI (with DVD logo). I'm unclear what efi is (something in the bios).
    it doesn't like my drives - says they need GUID instead of MBR... So I formatted the partition as GUID (Mac journaled) and win8 wants to format it and still won't let me past picking a partition and formatting it. Needs NTSF. (I formatted it that way - and GUID / MBR problem. I've been round and round and gave up - only to WANT bootcamp and trying again. Thought I'd look and ask here.

    My specs OSX mav. Quadcore i5 - BOOT is a Samsung SSD 500gb)
    I tried creating the partition on it. (no go)

    also in the machine is 2TB HD. Tried partition on it... (as primary and 2nd and no go). I also have 3 external 3TB drives (which I unplugged from firewire simply to simplify the process.

    Things I wonder

    1. why won't the computer boot the win8 DVD upon BOOT options? (possibly no driver installed?)

    2. What is EFI (DVD) boot option? I suspect it boots without having DVD drivers?

    Why can't I format a win8 friendly partition?

    Ron in Michigan
     
  2. IA64 macrumors 6502

    Joined:
    Nov 8, 2013
  3. Rojoyinc, Feb 12, 2014
    Last edited: Feb 12, 2014

    Rojoyinc thread starter macrumors newbie

    Joined:
    Sep 13, 2011
    #3
    27" mid 2011

    I originally had a DVD drive in it - removed for SDD and 2TB HD. (which is why I THINK it won't boot from flash drive.

    So reading another thread on here... I tried again. Formatted my SD card in USB reader as fat and tried to restore (diskutil) the win8.iso to it. Says "restore failure could not validate source - invalid argument.

    Same happens if I try to (disktuil) restore the ISO to a bootcamp partition on the internal 2nd drive.

    It can't validate source (ISO?) trying to move it to the fat formatted SD/usb and will try and restore the ISO to it.

    So now I'm just gonna try (again) to copy the ISO to the SD/USB drive and will see if it then shows up as a boot device (under option/boot).
     
  4. Rojoyinc thread starter macrumors newbie

    Joined:
    Sep 13, 2011
    #4
    No luck - To sum it up - I can't seem to boot from anything except my SSD (OSX) or my EFI-dvd. It says I can't format a drive after booting from EFI.

    The only other boot option is a DVD - (external drive) selecting it kicks the drive in but soon stops with a white cursor flashing on a black screen. As if it can't read the disc. If I select EFI/DVD it boots the DVD and win8 starts to install, says setting things up etc... gets to select a partition and will not allow me to use any partition. I pick bootcamp and format anyway and it says it can install. (See image below). HOWEVER after rebooting to OSX - and looking at the drive in diskutil, the bootcamp partition is there and says it's formatted in NTSF as it should be. Is there a bio's option or something that will allow me to work after booting EFI?
     

    Attached Files:

  5. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #5
    That's exactly why it won't boot from an external source. In 2011, Apple changed something with the EFI/Firmware where Boot Camp Assistant looks for Windows to be installed from the built-in SuperDrive.

    Also, Apple's firmware is locked down. There is nothing for the end user to access.
     
  6. dangerly macrumors regular

    Joined:
    Oct 27, 2009
    #6
    Nope.
    I have a late 2012 27" iMac (no superdrive) and am encountering the same troubles the thread starter has.
    No way to install windows 8 with bootcamp.
    If somebody knows the solution please stand up and write it down!
     
  7. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #7
  8. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #8
    Same troubles perhaps, but a different issue because Apple does allow USB installs of Windows on systems that did not come with an optical drive (MacBook Air, rMBP, 2012 and later iMacs).
     
  9. Rojoyinc thread starter macrumors newbie

    Joined:
    Sep 13, 2011
    #9
    The other "HOW TO THREAD" didn't work - I had tried that when I found the exact same text on another forum. I don't get any ORANGE WINDOWS boot option. I can ONLY boot from EFI (DVD) which boots the win8 DVD in external reader. Installs win8 (starts to) until it gets to partition selection which then spits up due to MBR and GPI when booting from EFI. Hitting FORMAT to a partition anyway makes the partition then become "unallocated space".

    The flash drive never appears as a bootable device.
    I hate having to use my PC for PC games. = (
     
  10. Rojoyinc thread starter macrumors newbie

    Joined:
    Sep 13, 2011
    #10
    Usually this works fine...
     

    Attached Files:

Share This Page